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From The Chief Editor's Desk
Within the past week, I've been reminded of how installing stuff from outside the official repository can be difficult. For much of the past 10+ months, I've been using the PIA (Private Internet Access) VPN. Their desktop client started popping up periodic messages urging me to "update" to the most current version. Not only was that annoying, but it also sent shivers down my spine as flashbacks to my Windows days flashed before my eyes.

But that wasn't the worst part of it. I downloaded the installer for the updated desktop client and followed the directions exactly for installing it. But noooooooooooo! It couldn't be THAT easy, now could it? Trust me, it wasn't. Even though all the previous versions of PIA's installer installed without a hitch, I hit the proverbial wall with this new version. It choked, complaining about not having libappindicator1 available. Never mind the fact that I had libappindicator2 and libappindicator3 installed. Never mind the fact that I made a soft link to libappindicator2, named libappindicator1. The PIA installer requires that I have sudo installed, as well as an edited sudoers file, and those are installed and working properly. Nothing I did made even the smallest difference. In all cases, the PIA installer exited without fully installing because of what it saw as or thought was missing on my computer. As of this writing, PIA's updated desktop client still hasn't been installed on my main laptop.
Fortunately, PIA also offers the choice of connecting to their VPN via openvpn. With openvpn, there is no "fancy" desktop client to make connecting to the VPN servers quick and painless. It had been quite a while since I had messed around with openvpn, so I had to go back and review the article I wrote about openvpn in the magazine a few years back. That old adage "use it or lose it" really did apply. So, I downloaded the openvpn files from PIA and set out to conquer my VPN connection using openvpn.
But, I missed the convenience of the PIA desktop client. It was easy and directly accessible from the desktop, even as a "normal" user. The openvpn method didn't offer the ease and direct access. First, I had to start openvpn as the root user. Then, I had to remember the name of the openvpn files. That just wasn't going to happen.
So, even though openvpn connected me to my preferred PIA VPN server in Atlanta, I still missed the choice of selecting and using the other PIA VPN servers. So, I took a brief break from laying out the magazine and created a quick Zenity dialog enhanced bash script that allowed me to choose from any of PIA's VPN servers, graphically. I haven't quite perfected the script, but it does work. It works only if I run it as the root user. Even sudo or gksu won't allow it to work as I would like, but I'll keep plugging away at it in my "free time." As a bonus, the script exits when the openvpn connection has been made, which means it has a lot less memory overhead than when using the PIA desktop client. But, at least I have full and unfettered access to all of PIA's VPN servers with a simple click of my mouse.
Who knows. Maybe it'll make a separate magazine article -- once I get the script working the way I want (being able to be run as a normal user is the ultimate goal, but I'd settle for running with elevated privileges, via gksu or some similar method).
Speaking of articles, I'm exploring the introduction of a new column called "Short Topix," with the first installment coming this month, in this issue. I don't know why I hadn't thought of it before, but I hope you like it and find it interesting. The next few months will dictate if this idea will pan out, and how often the column will appear.
This month's cover pays homage to National Crayon Day on March 31. Get out your crayons and unleash your creativity!
So, until next month, I bid you peace, happiness, serenity and prosperity.
Short Topix: iOS Bootloader Leaked, ET vs BitCoin
by Paul Arnote (parnote)
I'm going to try out something a little different this month. Quite frequently, I stumble across little tidbits of information that are either interesting or helpful. But many of these tidbits don't have enough "depth" to warrant a full-blown article for the magazine. So instead, I thought I might try to round many of them up into a "catch-all" type of article. We'll see how this goes. It may (or may not) end up being a regular feature in the magazine. Or, it could end up being an every-once-in-a-while article. The next couple or few months should be sufficient to gauge whether or not this will pan out.

Is Mining For Cryptocurrency Interfering With The Search For ET?
So many people are mining for cryptocurrency that they are snatching up all available GPUs (graphics processing units), so much so that researchers are having a difficult time procuring them for scientific pursuits. Most people -- you and me, for example -- typically think of gamers and users of high-end graphics systems as the prime "consumers" of the higher end GPUs. But then, we would be wrong. Nope. The cryptominers leverage the GPUs for the same reason that researchers do: their ability to analyze large amounts of data quickly. But the rising popularity of cryptomining has created a shortage of GPUs, as well as the accompanying price increases that typically goes along with things that suddenly are in short supply. So, researchers and data scientists are having considerable difficulties getting their hands on the GPUs they need to crunch the mountains of data they have to deal with. In the case of astronomical scientists, it's limiting the search for extraterrestrials, according to an article that recently appeared in a BBC report.
For example, SETI wants to expand its operations at two of its locations -- one in West Virginia and the other in Australia -- but finds itself unable to do so because of the lack of available GPUs. SETI uses the GPUs to analyze radio frequency data to see if ET is sending out any sort of communications. Even though SETI has the money to purchase the GPUs that they need, they just are not available. With cryptominers buying them up as fast as they are produced, SETI just can't seem to get the tools they need.
Hopefully, the "shortage" will be short lived, since some cryptominers are switching to using the new ASIC chip from Samsung and other chipmakers. Despite the arrival of alternate chip platforms, GPUs remain immensely popular with cryptominers, so the shortage may persist for some time to come.

iOS Bootloader Leaked To GitHub
A GitHub user who goes by the name ZioShiba posted the iOS bootloader, called iBoot, to a repository on GitHub. Apple leveraged the DMCA (Digital Millennium Copyright Act) to have the repository taken down, and in the process, may have inadvertently confirmed that the code leaked was the "real McCoy." According to GitHub's DMCA takedown policy, the copyright owner must "conduct an initial investigation to confirm both that they own the copyright to an original work and that the content on GitHub is unauthorized and infringing." Thus, Apple must own the copyright of the code in order to have it removed. The code had been forked several times, so Apple also had to track those down and have them removed.
Jonathan Levin, an author of books on iOS and MacOS, confirmed that the code "looked real," and matched the code that he has been able to reverse engineer. Meanwhile, Apple has stated that the release of the iBoot code will not affect security of hardware running iOS. It has also been reported by Motherboard (who also broke the original story) that not only was the iOS leak an "insider" job by a former employee, but that there is also additional iOS code that has yet to be widely leaked. The Cupertino folks may need to buy truckloads of Tylenol, as their headaches are just starting, if this is the case.

MPEG-2 Patent Expiration
The last patent covering the MPEG-2 video codec expired in the U.S. on February 13, 2018. While this might not seem like a huge deal, it likely will turn out to be. MPEG-2's low processing overhead has endeared it to video buffs around the world. And this is despite the emergence of newer video codecs, such as H.264 and VP8.
MPEG-2 is used as the encoder for ATSC broadcasts in the U.S. and South Korea, as well as DVB-T broadcasts in Australia, India, most of Europe, and Africa.
This means that manufacturers of TVs, DVD/BluRay players, USB or PCIe tuners, and professional production equipment no longer have to pay MPEG-2 licensing fees to MPEG LA. Of particular note is the Raspberry Pi, which has built-in hardware support for MPEG-2 decoder. Currently, users have to pay a $3.36 (U.S.) fee to unlock the MPEG-2 capabilities on the Broadcom VideoCore IV graphics processor. It remains unclear if the makers of the Raspberry Pi will now offer this "key" to unlock the MPEG-2 hardware capabilities for free. Also, Linux distributions will now be free to include MPEG-2 support on their LiveDVD media.

Facebook's Onavo Protect VPN Collects Data On ALL You Do
Ha! Just when you think that "privacy" on Facebook couldn't get any worse, it does EXACTLY that. Actually, the words "privacy" and "Facebook" don't even belong in the same sentence. Ever. It's so bad that Facebook is known to collect browsing information on people who are not Facebook users, and have never been Facebook users. Yes, Facebook's and Mark Zuckerberg's fortunes have been amassed on the backs of your private data, and by violating every aspect of your privacy.
On its mobile apps, Facebook tries to dupe users into using the Onavo Protect VPN. If users click on the "Protect" page, they are redirected to the appropriate app store for the platform to download the Onavo Protect VPN client. Having purchased Onavo years ago, Facebook has now "weaponized" it to the point where it's a VPN in name only.
Once installed, all network traffic is routed through Onavo's servers. It is there that everything you do on your mobile device is captured for Facebook's gain. It monitors and records every web page you visit, how long you spend there, every app you use and how long you spend using it, your location, your wifi information and just about everything else about your online presence.

Happy Birthday, Open Source (Definition)
Roughly 20 years ago, the "official" definition of open source was created. Of course, that wasn't the beginning of open source software. But it is an important milestone. The whole idea of open source software can probably be traced back to 1983 and Richard Stallman's GNU Manifesto. But the definition of open source as we know it gained steam and evolved not only from Stallman, but also the Debian Free Software Guideline.
Today, it is open source that is driving enterprise computing. Just imagine where we'd be today without Linux, GIMP, RedHat, LibreOffice, Apache, MySQL, PHP, Firefox, Kubernetes, and Android, among many, many others. An entire industry has grown up with open source at its core. Major companies, like Canonical, RedHat, Apple, Google, Facebook, and a whole host of others depend on open source.

Equifax Breach Worse Than Originally Reported
Back in September 2017 came a report of the largest data breach of the year, and one of the largest of all time. Equifax, the credit reporting agency, had been hacked. The breach affected 145.5 million people, revealing their names, addresses, Social Security numbers, and dates of birth. But, it appears that we didn't get the full story of the breadth of data stolen. It seems that tax identification numbers, email addresses, and driver license information was also among the data that was stolen. It's unclear how many of the 145.5 million people are affected by the improper access to the additional data. A spokesperson for Equifax has stated that Equifax was fully aware -- and always has been -- of the data that was stolen.
![]()
LibreOffice Writer Hacks
by Meemaw
As I did with LibreOffice Calc, I also saw an article about MS Word, where I wondered which of their changes also worked in LO Writer.
Out of the box, LibreOffice and MS Word each do a reasonable job of anticipating how most of us work. When you open a new document, it is a certain page size, in a specific orientation, with specific margins and spacing. Sometimes, though, your project is one that needs some customization. In MS Word, you can edit the Normal template, and then every word document you open will have those edits. In the above-mentioned article, the author recommends that you DON'T customize the Normal template, for the following reasons:
In LibreOffice, the Help files say that you can modify the default style, but only for the document you are creating. If you start a new document, the program's original default style will return. The best way to edit a document so you can open it in that style every time is to create a template.
Start a new document, and edit the settings with the formatting you want. Suppose you will be creating several user guides, all on letter sized paper, in portrait orientation, with ½ inch margins and two columns per page. Using a new Writer document, format your page with those settings, then click File > Templates > Save as Template. If you have your toolbar customized so your save button has a dropdown, just click the Save button, and hold it until the menu appears, then choose Save as Template.

Give your template a descriptive name (Writer-2Column) and save it (possibly in My Templates). If that is something you will use a lot, you can set it as the default template. Click File > Templates > Manage Templates and find your template. Right click on it and choose Set As Default. Now, every time you choose New Writer document, that template will open.

OK, so what if you have finished with your user guide and don't want it to open every time? Simply repeat this method, and choose another template (maybe the Default template, which is there as well). Right click and choose Set As Default.
If you need some sort of special template, you can also look in LibreOffice's Template Repository. You might find just the perfect template to use.
Line Spacing
Microsoft has edited its Default formatting since things are more in the cloud, and changed the default line spacing to 1.15, which makes everything look more casual. I don't really like it, but that's just me. LibreOffice's default is 1. If you want to change it to something else, be sure to include that in the template you just created.
Smart quotes
I don't worry about it too much, because I don't do a lot of HTML work, but "smart quotes" still cause trouble when dropped into HTML and certain file formats. This is not disabled in MS Word or in LO Writer. You can disable it here:
Click on Tools > AutoCorrect > AutoCorrect Options, then click the tab labeled Localized Options. The main window there shows the quotation marks at bottom right. Click on each one, and a window will pop up, giving you a choice as to what you want.

Paste Special
By default, Word retains the source formatting when you paste content. LibreOffice does, too. If you paste from other sources or another document frequently, you might have to change a lot of formatting. The other choice is to use Paste Special, in the Edit menu.
There are five options available. Select the one that works best for you. I usually use Unformatted text then format it myself. This isn't really a settings hack, but a way to work more effectively. I have copied information from tables, and then had an unnecessary table in my text document. I have also copied spreadsheet cells to a writer document. It works better if it's just text.
Default file location
Since you're using PCLinuxOS, LibreOffice defaults to your Documents folder when saving. However, you can change the default if you want. You can change it as follows:

This is also where the default location for templates is. After last month's article, dm+ posted this in the forum:
"In response to Meemaw's article on templates:
To change the default template of LibreOffice components:
https://help.libreoffice.org/Writer/Changing_the_Default_Template
(the procedure is not limited to text documents)
The saved templates (including the templates marked as default) are in the user's .config/libreoffice/x/user/template directory -- actually the directory defined in Tools > Options > LibreOffice > Paths"
Paragraph spacing
"By default, Word adds a bit of white space after each paragraph when you press Enter at the end of a line. This white space isn't a blank line; it's part of the paragraph leading. If you want paragraphs to flow from one into another without that white space, change the default as follows:
In LibreOffice, this is a document setting, although you can change the Default template to reflect it. Open a blank Writer document, open the Options menu, then click on LibreOffice Writer > Compatibility. I believe the matching item to check is "MS Word compatible trailing blanks."
The Mini toolbar display
Many MS Office users like the Mini toolbar, which displays formatting options when you select text. LibreOffice doesn't have one, so we don't have to worry about it. I always found it annoying, and at work in Outlook (the company's chosen email program), I have turned it off. If you were wondering what it is, I can show you here:

The formatting box pops up automatically when you highlight text.
The Normal style
In this item was a way to customize is the font and font size in MS Word. To change it for writer documents, you can go to Tools > Options > LibreOffice Writer > Basic Fonts. Here you can change whichever font you want and the next document you create will use these fonts.
Word selection
When you highlight part of a word and then extend that selection to the next word, Word automatically selects the whole word for you. The article described the options setting to use in MS Office to change that. LibreOffice doesn't do that, so we don't have to worry. I think it's better if your highlighting covers only what you choose to highlight rather than deciding for you what you want.
Spelling, grammar, and formatting
From the article:
Word likes to help us by identifying misspelled words, grammatical errors, and formatting inconsistencies, as we type:
I don't recommend that you disable these features; doing so makes you vulnerable to mistakes you might easily miss when proofing your work. If, on the other hand, you're writing the great American novel, you might find them distracting. The good news is, if you really must, you can disable them as follows:
In LibreOffice, you can change how your text is checked by choosing Tools > Language and Tools > AutoCorrect. In Language there are three sub-menus. You can choose (in each) "None - Do not check spelling" rather than your desired language to spell-check. I'm with the author though. I think you should not turn off the spell-check.

Also, you can go to Tools > Options > Language Settings > Writing Aids and change whatever you want. I don't recommend you change any of the settings - correct spelling and grammar are so important to your writing!

Margins
One thing you also have to set in your default template is the margins. In MS Office, it's in Page Setup. In LibreOffice, it is in Format > Page. You shouldn't have any problems formatting your beginning template as you see fit.
LibreOffice has been updated to version 6.0.1-1. You can see the Writer changes here.
I'm sure you can find many more hacks to make your work in LibreOffice Writer smooth and trouble-free. LibreOffice is my favorite!





DigiKam: Photo Management Basics
by phorneker
In the last issue, I presented an introduction to DigiKam and its basic interface (as well as a small sample of my photo collection). For this issue, let us discuss the basics of photo management in DigiKam.
As with many Linux applications, you should (theoretically) be able to launch DigiKam from any desktop. Because DigiKam was designed for the KDE (Plasma) desktop, it is best to launch DigiKam from the KDE (Plasma) desktop as many required libraries the application uses have already been loaded when KDE (Plasma) desktop was launched.
If you were to load DigiKam from, say, the MATE desktop, the basic KDE libraries would have to be loaded first, increasing the time needed to launch the application, not to mention that the full functionality of DigiKam cannot be guaranteed when running on non-KDE desktops.
(In fact, this is one reason why Shotwell was included in the repository.)
Now back to DigiKam.
Each time DigiKam is loaded, DigiKam checks the directory (or directories) where your photo collection is stored for newly added (or deleted) photographs and updates its database accordingly. This could take some time if you have a large collection of photographs.

In this example, the process was immediate as no new photographs have been added or deleted.

The left panel in DigiKam is where Albums are managed. Here, we have a (partial) structure of how photographs on my laptop are organized. (As we can see, this is quite a mess).
| If you are doing photographic work for someone else on the same machine you are doing photographic work for yourself, it is a good idea to create subdirectories to separate work you do for others from work you do for yourself. |
The root level entry named Albums is the root level of the database where DIgiKam stores information on each photograph. The entry Pictures refers to the ~/Pictures directory on the hard drive. These two entries are created when DigiKam is2 first launched.
You can right click on any entry in this panel except for the root level entry Albums. What pops up depends on which entry you right click on.

For the Pictures entry, only two items appear in the popup menu, one to create a subdirectory in ~/Pictures, and one to open the Pictures directory in Dolphin (the KDE file manager).

In this example, I right clicked on the Architecture folder. Here, in addition to the two items that we just discussed in the first example, we have options to rename the folder, reset the icon of the folder (icons for folders can be changed within Dolphin), find image duplicates, refresh the contents of the folder, import and export photographs in the folder, delete the folder, or show information about the folder.
| From the keyboard, you can hold down Control then press N to create a new directory. Holding down Shift, then pressing the F2 key allows you to rename the folder, and holding down Alt and pressing the Return key shows you information about the folder you right clicked on. |
Selecting Properties here will allow you to edit information about the selected folder.

Here, Albums in DigiKam are titled. As titles are derived from subdirectories, changing the title here also changes the name of the subdirectory where the folder (or subfolder) resides within ~/Pictures.

Clicking on Category allows you to assign a category to the album. Categories are searchable from the search function found elsewhere in DigiKam. Here2, there are predefined categories that can be assigned to folders (as well as individual images). As one could guess, you can add categories by simply typing them in the category box.

Likewise, Captions are typed in a freeform box just below Category. Information here is stored in DigiKam's internal database.
Below that is a calendar where you can assign a date for the Album. This date could be any arbitrary date, but it is suggested that the date could be the date the album was created, either in DigiKam, or the date the album of photographs were originally taken (which could well predate computers).

The button Oldest refers to the oldest date assigned to the photograph in this Album. The same is true for the Newest. The button Average “calculates” the date based on the dates of all photographs in the album.
| In UNIX systems, including PCLinuxOS, the date of a file is stored as a long integer based on the starting date of January 1, 1968. Hence the Average button on DigiKam calculates the average of all UNIX dates of all photographs stored in the affected folder. |
Let us now choose a folder, such as Artwork. (I scrolled down the directory so nothing is highlighted for the moment.) One of the items that appeared in the popup menu is called Find Duplicates. Here, I want to show an example of what DigiKam considers to be a duplicate image.

In this instance, I have two different versions of the same image. One reason for this is to preserve the original image while I work on the other image (as a copy). That way, if something gets messed up in the process, I have an original to start over with, saving significant amounts of time trying to recreate the original image.
Another reason for having two different versions of an image is that one version can have a watermark embedded on the image (this can be done in DigiKam) to identify photographs as being yours.
What we see here is a Thumbnail view of the ~/Pictures/Artwork directory. We can change the view to a Table view by clicking on Table.

Now we have a view of the photographs with a thumbnail, filename, rating (if there is one), creation date and time (the UNIX timestamp), and title (if assigned). Here, there are two versions of the same artwork I have created, one has a watermark, and the other does not.
If photographs have been geotagged, the Map button would show you a map of where the photograph was taken. If images have not been geotagged, this is what the Map button will get you.

This is what you would want to see if you are into astronomy as the names of the star clusters are shown here. Now, let us click on Preview.

From the last issue, this is what we got when we clicked on the highlighted photograph in the center panel. We get the full view of the selected image, as well as a filmstrip of adjacent images in the directory. Here, we have the watermarked version of this artwork.

...with the watermark being my signature.
The Full Screen button allows DigiKam to take up the entire screen. Slideshow allows you to present a slideshow on your screen made up of directories of photographs, or selected photographs within a directory.
| Pressing F9 will start the slideshow with all photographs in the folder we are currently working in. Pressing Alt-F9 shows only photographs selected within the current working folder. Finally, pressing Shift-F9 includes any subfolders within the current working folder for the slideshow. |
On the left side of the left panel are a set of tabs providing other functions DigiKam has to offer for photo management. Below Albums are Tags, Labels, Dates, Timeline, Search, Similarity, Map, and People.

The Tags tab allows you to assign tags to photographs or videos that is primarily used to organize for easier search and retrieval. This type of tagging is not the same as the EXIF tagging used to supply information to photographs taken with a digital camera, though their purposes are similar.

DigiKam comes with a Tag Manager. As with Albums, tags are organized in a similar fashion. The developers of DigiKam supplied a predefined tag called People with a single subcategory named Undefined. I have expanded the People tag to show the full tag.

The Tag Manager has three functions, Organize, Sync Export and Tag Properties.

Tag Properties allows you to edit tags for use on photographs. There are only three properties that can be assigned to a tag. Only the Title is required as that is the name assigned to the tag itself.

To edit Tags, the tag must be selected in the Tag Manager. The icon assigned to the tag can be changed as well making it easier to identify specific Tags. When you click on Icon, DigiKam opens a dialog box for selecting icons. This is the same dialog box used to select icons in other parts of KDE, such as the launcher items on your Plasma desktop, and hence the dialog box takes some time to load.
Keyboard shortcuts can be assigned to tags for faster application of tags. Simply click on the button next to Shortcut, and type the key you wish to2 assign to that particular tag.
When finished, click on Save to confirm changes, or Discard to cancel changes made to the tags.
Clicking on Organize brings up this menu.

Edit Tag Title (or pressing the F2 key) is the same as clicking on the Title in Tag Properties and typing in the name of the tag.
Reset Tag Icon resets the icon assigned to the tag to its default, namely the price tag shown in Tag Properties.
Create Tag from Address Book only works if you use the address book that comes with the Plasma desktop.
If you have selected a number of tags in Tag Manager, you can select the remaining tags that have not been selected, at the same time deselect the tags that have been selected by choosing Invert Selection from the menu.
Expand Tag Trees and Expand Selected Nodes allows you to see the full contents of your tags.
Remove Tag from Images does just that with images that have the selected tag assigned.
Delete Unassigned Tags does just that removing the clutter in Tag Manager created by having tags where no pictures have been assigned.

This menu takes care of some housekeeping details of tagging photographs. Here, tags from the database maintained in DigiKam are written to photographs, read from photographs, or the database can be cleared of all tags assigned to photographs.

...and finally, you can add tags to the list by simply typing the tag into the search box and clicking on +. Tags are added to the currently selected tag.

Labels are different from Tags in the sense that they are tracked within DigiKam's database only as opposed to assigning directly to photographs. (Shotwell, also in the PCLinuxOS repository, has this feature as well for the same purpose.)
Labels are used mainly for grouping of photographs for easier selection and processing. In DigiKam (and Shotwell) there are three types of labels, namely Rating (from one to five stars), Pick, and Color.
For this panel, clicking anything here shows images and video with the selected label assigned.

Photographs can also be viewed by date (this feature is also available in Shotwell), though this is not an accurate way to select photographs as this feature depends upon the UNIX timestamp assigned to photographs, which as we know is not necessarily the date the photographs were actually taken, but the dates the photographs were stored and/or retrieved from hard drives, backup discs, or wherever the data is stored.

Likewise, the Timeline feature is another graphical way to view photographs. This feature is not very useful unless the dates on each of the photographs of the entire collection are correct as to when the pictures were taken.
The Search function is quite straightforward, and works best when photographs are tagged.
Before we get to Search, I would like to show you the Similarity tab. When clicking on this for the first time, we get this message:

Click Yes here to have DigiKam create digital fingerprints of your photo collection. This will take some time for the fingerprint to build, especially if you have a large collection of photographs.

When finished, DigiKam will display a notification to that effect (works best when running the KDE Plasma desktop).

The Similarity tool is a powerful search tool for photographs. Its effectiveness depends upon keeping the database of image fingerprints up to date. Duplicate photographs are detected by examining the differences in the image fingerprints. The Update Fingerprints button updates the database of image fingerprints. To search for what DigiKam considers to be Duplicates, click on Find Duplicates.

Here, DigiKam has found a number of duplicate images in the photo collection. How do these duplicates happen in the first place?
There are two other tabs within Similarity, namely Image and Sketch.

When Image is selected, simply drag and drop a photograph onto this panel so DigiKam can search your collection for duplicate images.

Finally, Sketch allows you to search your collection by drawing a color sketch that approximates what the image you are looking for looks like. (Unless you can sketch your image well enough for DigiKam to recognize the image, I would recommend tagging your photographs for searching instead.)

The Map tab is used to search for photograph that have been geotagged, that is, photographs that have been tagged with geographic information such as country, city, state or province.

...and finally, the People tag is used for a face search. This is why the developers of DigiKam included a People category with a Unknown tag in the Tag Manager by default.
Now that we have seen the photo management capabilities of DigiKam, the next thing that comes to mind is this:
How do we get photographs into DigiKam in the first place? The answer to that question is that there are four ways to do this.
The first way is to copy photographs to the Pictures directory within your home directory (hopefully organized in some way as DigiKam creates subalbums out of subdirectories in the Pictures directory), then launch DigiKam. DigiKam will scan that directory against its database for changes to the collection.
The second way is to upload photographs from your digital camera(s), USB flash drives or card readers.
The third way is to digitize photographs with a scanner (or all-in-one device such as an Epson Stylus NX-415).
The fourth way is to retrieve them from one of the photo sharing services available on the Internet such as Google Photos or Smugmug (or simply import them from a file server containing photographs).
Many digital cameras connect to PCLinuxOS as a USB Mass Storage device or as a PTP device (PTP stands for Picture Transfer Protocol and is the basis for the PictBridge protocol used for direct communication between digital cameras and printers). Most likely, this is how you will be able to connect your camera to transfer photographs to DigiKam.
The gphoto2 package was developed long before the USB mass storage protocol became the standard for digital cameras (including those attached to phones). This package continued to be actively developed, especially for cameras that transfer images in RAW mode, that is uncompressed color and image data generated by the digital camera (mainly digital SLRs) itself where the processing is done by software such as DigiKam and GIMP rather than the camera itself.

The package kamera is part of the Plasma desktop that allows KDE to manage digital cameras through the gphoto2 package. The setting is found under Removable Storage in System Settings.
Use this only if you have a real need to use it, such as a digital camera that connects through gphoto2, but not as a USB mass storage device or as a PTP camera. One example of this is a first generation digital camera that connects to a serial port (or through a serial port to USB adapter), which will obviously not be detected by DigiKam or the Plasma Desktop as that is a serial device.

DigiKam has its own gphoto2 configuration dialog box. This dialog box is launched by selecting Import -> Cameras... -> Add Camera Manually from the main menu. If your camera connects to a USB port, you should be able to Auto-Detect the camera by clicking on the appropriately named button.

As of version 5.8, DigiKam can import photographs from SmugMug and Google Photos. Here, the USB storage device and card reader options are greyed out. If you have a camera attached that supports the USB mass storage protocol, that camera will appear under USB Storage Devices. The same is true of USB flash drives (or external CD/DVD reader/writers that have a CD or DVD inserted) that contain photographs. The Card Reader option is available if you have a memory card inserted in the card reader (internal or external to your system).
On my laptop, a HP Compaq 8510p, there is a built-in card reader that supports SD/MMC, SD-HC and PCMCIA cards. The latter is an old-school mechanism used not only for memory storage, but also for network adapters, USB adapters, memory card readers (for Compact Flash, SD/MMC, Sony's MemoryStick and the obsolete SmartMedia), and (dare I say it) 56k modems.
I have two external card readers that support just about every type of memory card that existed at one time or another. One is a Kodak branded memory card reader, and the other is a GFM (sold at the Meijer chain of superstores) branded memory card reader.
Import from remote storage, Add Images and add folders all do basically the same thing. Import from remote storage, however, allows you to import photographs and videos from servers connected to the UNIX filesystem. This function uses the standard KDE file dialog rather than a customized version for local importing of files.
Import from Scanner launches DigiKam's built in scanner tool. As with xsane or another utility such as Epson's iScan utility for Linux, the scanner tool first searches for a usable scanner device.

Here, DigiKam detected the Epson Stylus NX-415 and shown here are the basic options for scanning photographs. For the NX-415, DigiKam selected a 600dpi scan resolution (which happens to be what I use most the time when scanning images). As with xsane, you can preview the scan (at 300dpi) before performing the actual scan. For the NX-415, DigiKam used the epson2 driver rather than the epkowa driver developed by Epson (which also happens to be open source).

Selecting Scanner Specific Options yields the same controls found in Epson's iScan utility for Linux.
DigiKam can be setup to import and export photographs from Google Photos (also known as PicasaWeb). Selecting Import from Google Photos/PicasaWeb will open Firefox to allow permission for kipi-plugins to access Google services.

After clicking on Allow, you will get a six digit code to enter into DigiKam to confirm permission to access Google services.

At that point, you should have access to photographs stored in Google's cloud. If you have a smartphone or tablet with a recent version of Android, those photographs should import to DigiKam.
Likewise, import and export to cloud services supported by DigiKam are setup the same way.
This was just the basics of photo management. There is a lot more you can do with DigiKam that makes this a powerful application for PCLinuxOS and digital photography.
Next issue, I will discuss DigiKam's ShowFoto, the photo editor that rivals that of the GIMP in terms of functionality.
PCLinuxOS Family Member Spotlight: Ratt Salad
As told to YouCanToo

What is your name/username?
Name: Oh, I have many, many... a lot, most commonly Abaddon or Muffin. Username: Ratt Salad
Rat Salad is actually a song by Black Sabbath, but my girlfriend thinks I'm a dish if that helps at all.

This is not a recent pic, I no longer have the tail... a fall from grace.
How old are you?
Wow, what year is it now? I stopped counting after 500! Apparently, I was born yesterday.
Are you married, single?
Happily, recently no longer un-re-divorced. I am currently dating an amazing person named Tria. She has been blind from birth and does not know any better. I also disconnected her braille-terminal, so this is between us.
How about Kids, Grandkids (names and ages)?
There are 2 beautiful girls named Dayna (14) and Lotus (12) who claim to be my offspring. Quite charming, I believe them. I am told that there are also blood tests that confirm this.
Do you have pets, what is your favorite?
Alas, my cat Pebbles (Flintstone) an orange tabby is no longer with us. Well, actually she is. I buried her in the backyard, underneath the Cherry tree that she planted herself!
Are you retired, still working and if working, what do you do?
I am a full-time megalomaniac, seriously it's not a part-time job. I am also a medical device prototype builder which allows me to work from home/the bar. I much prefer to volunteer my time at a local nursing home where I test my prototypes on the unsuspecting ... I mean the willing, yes that. Some of these folks are amazing chess players!
Where do you call home? What is it like? IE: weather, scenery
Right now I live in Ontario, Canada (recently corrected by another forum member). Summer is fantastic, Winter could not convince anyone of "global warming".

Toronto, Ontario Canada
I am a bit of an Urban Guerrilla, but Canada is a huge country (more than 9 inches wide on the map) and does have some fantastic places without buildings that are well worth a visit. But, home for me is still Tooting (London, England). If I die, and I'm not saying that I will, I would like my ashes scattered over the Thames.

Tooting Broadway, London, England
Where did you go to school and what is your education level?
Skool? Many countries. I acquired my BSC in Applied Mathematics at Trent University, BBA and LLB at York University (Founders College and Osgoode Hall respectively). Education level? Still wondering what I was doing at University!
What kind of things you like doing? hobbies, travel, fishing, camping?
I love kissing girls, skydiving, jigsaw puzzles, chess, battle chess and neon lights. I like Classical, Blues, Motown and Heavy Rock/Metal (absolutely nothing else). I play drums (apparently not very well), piano, 6-string and bass guitar. I enjoy writing computer software (can I write something for you?). it keeps my mind sharp and challenged, but does not help my spelling or grammar (you are spell-checking this, right?).
Why and when did you start using Linux?
This may sound insane, but it's actually true. In 1998, I walked out of a Dairy Queen, completely buzzed on Maple-Caramel-Honey and found Red Hat 5 discs in the parking lot. I took them home, discovered that it was way more fun than trying to program a VCR ... and well, here we are.
What specific equipment do you currently use with PCLOS?
A mouse pad... with a mouse? I have several machines for various tasks, nothing noteworthy.
What would you like to see happen within PCLOS that would make it a better place. What are your feelings?
I have been using PCLOS since pclinuxos-ZEN-mini-x32-2012.1. I have introduced many people to it and they still use it too. I also use pclinuxos-mate-2014.05 and an Xfce (Phinx, but I don't have the original ISO date). I also have 64-bit versions of all three. Unlike most folks, I do not have the need to reinstall my OS every ... well ever! It works, always has and that's all that I ever want it to do. I would like PCLinuxOS to stay the way it is. Free, independent, doing things the right way.
PCLinuxOS Family Member Spotlight is an exclusive, monthly column by YouCanToo, featuring PCLinuxOS forum member. This column will allow "the rest of us" to get to know our forum family members better, and will give those featured an opportunity to share their PCLinuxOS story with the rest of the world.
If you would like to be featured in PCLinuxOS Family Member Spotlight, please send a private message to youcantoo, parnote or Meemaw in the PCLinuxOS forum expressing your interest. ?
ms_meme's Nook: In The Sandbox
LibreOffice 6.0 Released
by Meemaw

The LibreOffice organization updates their office suite regularly. The thirtieth of January saw the newest update, LibreOffice 6.0, and reading through the new features list was interesting. A Tech Republic article stated,
LibreOffice 6.0--the latest version of the popular open source office suite--was released by The Document Foundation on Tuesday. While the project has been on an approximate six-month release cadence since the debut of LibreOffice 3.3, the release of 6.0 brings significant improvements as well as code refactoring under-the-hood to ease development of new features going forward.
Let's look at a few of the new features.
Writer
There's a new menu called Form. I believe it was in the Tools menu, but now it is a menu of its own, allowing you to design forms.

Export to ePub to create e-books - this was an extension in 5.4 but it's in the menu now.

Both of the choices in this menu have Export Directly (which accepts the defaults without giving you a choice) and Export (which gives you a configuration screen with settings you can change).
Image rotation is better within a writer document. The new tool called rotate, does so in 16-degree increments.

Mail merge can use spreadsheet files (ods or xlsx) as a data source!!! (This was a big thing for me!) In previous versions of LibreOffice, you had to export your spreadsheet to a database, and merge using the database. I always thought this seemed like unnecessary work, and looked for another way to do my letters by mail merge. I usually did the letters in LO, changing the spreadsheet to a database, but now, when you choose the mail merge wizard, you can designate your spreadsheet as the file you want to use for the merge, without having to mess with a database. It's very easy. Unfortunately, you still have to convert your spreadsheet to a database for labels. I do all my labels in gLabels, where you can use the spreadsheet file (saved in csv format). Hopefully, this improvement will be upcoming in LO.
Calc
The Styles menu has been added to Calc.

I don't do much with styles, so I don't know much about that feature. I have several templates that are formatted the way I want them, and don't create any kind of different style. If you do, it's easier to access now.
Protect Sheet is in the right-click menu. I have several spreadsheets that are company records. I back them up several ways, and have passwords in place. However, it is an extra security measure if the sheets (some of which are payroll records from past years) can be protected against change. This particular spreadsheet shouldn't be locked so it can't be changed at all (because I'm still adding records this year). LibreOffice has a feature called Protect Sheet, located in the right-click menu of the tabs. Here it is possible to right click each sheet tab and choose Protect Sheet. This way the finished pages can be protected, and the current, unfinished one is still open for editing. Right-click on the tab for the sheet you want to protect, and choose Protect Sheet. You will be asked to enter a password (twice).


Enter your password, and the sheet will be protected. You will notice a lock icon on the sheet tab. If you need to unprotect a sheet for some reason, right-click the tab again and click on Protect Sheet, which will look like a pressed button in the menu. Put in your password and the sheet will "unlock".
You can now export a spreadsheet as a png or jpg, as well as a pdf or xhtml. The export menu now includes those additional items.
Impress
Ten new Impress templates have been added. Also, LO has changed the default slide format to 16:9 to accommodate newer screens.
General
Many of the documents import (from other programs) have been simplified, and new formats have been added. There are also several new fonts.
The Elementary icon theme has been added. I've been using it, and I like it. It seems more compact and cleaner than some of the other icon sets.
The Customize window has been redesigned.

The Notebookbar has been redesigned as the Groupbar Full for Writer, Calc and Impress. Remember, the Notebookbar was designed for those who liked the MS Office "Ribbon". You can click View > Toolbar Layout > Notebookbar, and your toolbar will change. I've never been fond of the Ribbon / Notebookbar, so I generally use the Single Toolbar with the Sidebar. I'm sure that seems repetitive, but I close the Sidebar part of the time. However, LibreOffice has designed some more toolbars you might want to try. If you have chosen the Notebookbar in the View menu, then click on View > Notebookbar, and you will see six different versions.

You can choose the Tabbed or Tabbed Compact bar for Writer. Not all of the new Notebookbar designs are available in Calc or Impress, only Groupedbar Full. All redesigned bars are experimental features, so if you don't see this menu, you need to go to Tools > Options > Advanced, activate experimental features, then restart LibreOffice. I have been playing with the Tabbed Compact. It doesn't seem too bad, and I can have the Sidebar open as well. My work monitor isn't so big, so I need the space rather than the toolbars.
![]()
I especially like the shortcut bar at the top left, which stays there no matter which Notebookbar you select. You can also customize it with a few much-used items. Mine has New, Open, Save, Print Directly, Undo and Redo. I'm sure they had many requests from people because there is a similar one on the left end of the titlebar in all the MS Office programs (and the only thing I like about them).

Also, if you are using one of the Notebookbars and there's something you need that you can't find, you can click on the gear or Menu dropdown at the right side of the bar and choose Menubar. Your original Menu bar will appear and you can access the item you couldn't find in your present configuration. The gear or menu is in all the Notebookbar types, so you can get back to something else in case you don't like what you have chosen. Depending on which Notebookbar type you choose, it can look one of two different ways.

Cloud Service
There is even a cloud service, called Collabora Online, which uses LibreOffice for collaboration between several locations. It looks like it might be interesting, and very useful, but it's out of my price range. The fully supported version of Collabora Office and Online starts at the price of € 17/user/year.
Summary
There are loads of new features for you to play with. Hopefully you'll find that LO 6.0 is even more wonderful than before. I have included links to the New Features page, LO 6.0 Release Notes, the online help and the online forum (with questions that have been asked already).
https://www.libreoffice.org/discover/new-features/
https://wiki.documentfoundation.org/ReleaseNotes/6.0
https://help.libreoffice.org/latest/en-US/text/shared/main0108.html?&DbPAR=WRITER&System=WIN
https://ask.libreoffice.org/en/questions/


So You Want To Be A YouTuber? With PCLinuxOS You Can ....
by Alessandro Ebersol (Agent Smith)

Last year, the CEO of YouTube, Susan Wojcicki, announced that only the mobile version of the site has reached more people between 18 and 49 years than any television network, open or subscription. YouTube today is the third most visited site in the world, and is a video platform that has more than one billion users.
Every day new YouTubers appear and the big channels serve as inspiration for small and medium channels. This new profession/activity has shown that it is possible to achieve incredible results with this media, and, in a way, this site (YouTube) came to democratize communications on the Internet (of course, it was more democratic in the beginning, since YouTube is cutting the monetization of videos and censoring other videos lately, but that's a conversation for later).
And with the popularity of YouTube in various formats (mobile, PC, tablet, smart TV), to be a Youtuber is no longer synonymous with idleness, a mere joke or waste of time.
There is room for both individuals and companies, and this communication phenomenon ended up creating a new profession. Yes, today you can live from YouTube (but as I said, much more difficult now because of the new YouTube policies).
As an example, see the case of the most famous YouTuber. He is a Swede who has 27 million followers. Felix Kjellberg, creator of the channel PewDiePie already had 4.78 billion views with his humorous posts about games. He offers tips and makes analysis of games directly from his home and earns on average US $4 million per year.
But how do I start?
Well, a segment of YouTube videos that is constantly growing are the video gameplays, and reviews of games with live captures, walkthroughs with or without voice over. I myself have a channel PCLinuxOS Brazil and I post videos and relevant information for the Brazilian PCLinuxOS community, as announcements and some gameplays. All videos of the channel are made in PCLinuxOS.
So, I'll start this series of articles, giving tips on how you can use PCLinuxOS to start as a YouTuber, creating your channel and uploading your videos. The theme will be gaming, gameplays and video walkthroughs. And in this first part, I will explain how to capture videos of DOS games.
DOSBOX, the versatile DOS emulator
DOSBox is a versatile DOS emulator, with which it is possible to have virtual machines running programs written for MS-DOS. I will not dwell much on its features, but I'll just point out a few features that are unknown to most users. DOSBOX can capture MIDI sequences, audio WAV and AVI video. Below is the list of special keys settings in DOSBOX.


Then, from the DOBOX version 0.65 onwards, you can capture the video that is running in DOSBox screen with the CTRL-ALT-F5 key combo. Press it once to start recording, a second time to stop recording.
The video mode currently emulated determines the resolution of the captured video, and the game or application currently running determines the name of the captured file. If the current application is changed while a movie is being recorded, the file name will not be changed, but if the video mode is changed, the current recording will stop automatically and a new movie on the new resolution will be created with the name of the last application running.
That is, if it is a low resolution video, the output video will be in 320x240 resolution, if the resolution is higher, 640x480 (VGA), and so on for higher resolutions.
As with screenshots, any filter will not be recorded or affect the content of the captured video.
But in Linux, there is a problem ...
Well, as stated above, the DOSBox video capture feature is activated pressing Ctrl-Alt-F5 simultaneously. Unfortunately, Linux or any other Unix-based system with X11 and virtual text consoles, this key combination will never come to DOSBox. Instead, it will be generally intercepted by the X server and open the fifth text console (tty5). The easiest way around this is to remap the video capture feature to another key combination. This can be done through the DOSBox keymapper, which starts from DOSBox after pressing Ctrl + F1 (only works if DOSBox is in full screen) or running DOSBox with dosbox -startmapper.
Now to succeed, we have to change this setting. Then, start DOSBox, switch to full screen (alt-enter), and press ctrl + F1. A screen should appear, as below:

Then, there is the command to record video is configured to: F5 + mod1 + mod2. The mod keys are respectively ctrl (mod1) and alt (mod2).
I did the following: kept mod1 + mod2, but changed the F5 key by the V key. So when I start or end the recording of my videos, I press ctrl + alt + V, which is not a common combination of keys in any DOS program (I, for one, have never seen this combination).
So my setup looks like this:

The resulting video will be stored in the DOSBox capture folder (~/home/.dosbox/capture).
The captured file extension will be AVI, which is a container format. The video part of the movie is encoded with the ZMBV 32-bit CODEC (Zip Motion Block Video), which allows a reasonably fast encoding of low color content.
Fortunately, ZMBV is directly supported by FFmpeg, so any media player that uses libavcodec (FFMpeg codec library) can play the captured videos. This includes MPlayer, VLC and many others. Mostly, the video can be edited by any native video editor in PCLinuxOS (OpenShot, Shotcut, Kdenlive, Flowblade, Pitivi, Kino, Lives, Cinelerra), or even Windows video editors (like VSDC, which I use). And, of course, you can convert to any format supported by FFMpeg (MP4, MOV, MP2, OGV, etc ...)
I hope you enjoyed this introduction. In future articles, I will address how to create videos of computers and video games emulators, as well as PCLinuxOS native games and emulated games via WINE.


Make Naughty Programs Be Nice
by Paul Arnote (parnote)
Believe it or not, the Linux system assigns the same priority to nearly every running process (program). There are a few exceptions, but the vast majority of the running processes are assigned the same priority -- zero (0). In this way, every running process has pretty much the same access to the core Linux system as every other.
Most of the time, this arrangement works out well. But sometimes, you might want a process to have more or less priority. You might want it to have a higher priority so that the system assigns more resources to it. Or, you might have a program that is consuming more resources and is slowing down other processes, causing an overall system slowdown. Some processes might not be as important to you, so assigning them a lower priority saves CPU time and cycles for those processes that are more important. Similarly, the opposite might occur, where you might want a process to have a higher priority because of its relative importance to you at that particular moment.
Fortunately, there are two commands in Linux that allow you to change a process's priority. Those commands are nice and renice. To use either command, you must have administrator access (be the root user). The priority scale runs from -20 (highest priority) to 19 (lowest priority). It's important to remember that negative numbers have higher priority, and positive numbers represent lower priority.

Above is a screenshot of the top command run in a terminal window. Notice that the fourth column from the left is labeled "NI." That is the priority, or "nice" level, of each process. In this particular screenshot, the "nice" level for all the processes is zero ("0"), the default value.
If you look long enough (or in a bigger terminal window), you will see processes that belong to the root user that have a nice/priority level of -20. You would be ill advised to change the nice/priority level of these processes. Many of these processes are vital to your system running smoothly. You really don't want to mess with these vital processes.
It helps to think of the nice command as a sort of launcher. Let's just say, for the sake of argument, that I wanted to launch Firefox with a "nice" level of 10. All I would have to do is launch Firefox like this:
nice -10 firefox&
Once Firefox launches, rerun the top command. You should see Firefox's "nice" level is now changed to 10, indicating that it is running with a lower priority. Similarly, if I wanted to launch Firefox with an increased priority or "nice" level, I would enter the command like this:
nice --10 firefox&
Rerunning the top command after Firefox launches, you should see that Firefox's "nice" level has been set to -10. This means Firefox is running with higher priority.
Take note of the slight difference in the commands. In the first nice command example, we lowered Firefox's priority with -10. This is a positive 10. The dash before the "10" is just the signal to the command that this is a command parameter. Notice in the second nice command example, where we raised Firefox's priority to -10 with a --10. The first dash indicates a command parameter, and the -10 is the actual value we passed to the command. Also, if you don't specify a "nice" level, nice will default to a nice level of 10. The ampersand at the end of each line pushes the task to the background and frees up the command line for other uses.
So what if you have a process that's already running and you want to change its nice level? That's what renice is for.

The format is slightly different for the renice command. Instead of specifying a program's name, you use the PID (process ID) number. In the screenshot above, you can find the PID in the first column of the output from the top command. Don't forget that you will need to have administrative privileges (be the root user) to run these commands.
So, if I want to change the nice level of Firefox, I can issue the command like this:
renice -n 15 -p 2996
The -n parameter is the new nice level I want to apply to the Firefox process, and the -p parameter is the PID of the currently running Firefox process. This particular command will decrease/lower the priority/nice level of Firefox.
Similarly, if I want to increase/raise the priority/nice level of Firefox, I would enter the command like this:
renice -n -15 -p 2996
It really is that easy.
If you have multiple users on a system, you can also "renice" all of the processes belonging to a particular user or group. Instead of the -p parameter and the PID, use -u username for a particular user, or -g groupname for a particular group of users.
Summary
With the nice and renice commands, you easily can tweak your computer to get maximum performance. You don't have to "just accept" the priority that the Linux system assigns to each process.
Just one additional note, though. You can lower the nice level/priority of a process as a regular user, but you have to have administrative privileges (be the root user) to raise the nice level/priority of a process. However, I find that it's much easier to just always change the priority of a process as the root user. This helps eliminate having to remember when you have to have administrative privileges and when you don't. If you always execute the commands with administrative privileges, you never find yourself in a position where it works sometimes and not at other times.
Now, go forth and make the naughty be nice.
PCLinuxOS Recipe Corner

Biscuits and Gravy Casserole

INGREDIENTS
1 lb bulk mild breakfast sausage
1/2 cup chopped onion
1/2 cup chopped red bell peppers
1 package (8 oz) white button mushrooms, chopped (about 2 cups)
1 teaspoon pepper
1/2 teaspoon salt
1/4 teaspoon garlic powder
1/3 cup all-purpose flour
3 cups milk
2 oz cream cheese, softened
1 can (16.5 oz) refrigerated buttermilk biscuits
DIRECTIONS
1. Heat oven to 350F. Spray 13x9-inch baking dish or 3-quart casserole with cooking spray. In 10-inch nonstick skillet, cook sausage over medium-high heat, stirring occasionally, 7 to 8 minutes or until no longer pink; remove from skillet, and drain.
2. In same skillet, cook onion, bell peppers, mushrooms, pepper, salt and garlic powder 3 to 5 minutes, stirring occasionally, until tender. Add sausage back to skillet. Stir in flour to coat; slowly stir in milk, and add cream cheese, simmering over medium-high heat 5 to 8 minutes and stirring until slightly thickened. Add hot sausage gravy mixture to baking dish.
3. Separate dough into 8 biscuits; cut each biscuit into quarters, and place on top of hot gravy mixture in baking dish. Bake 27 to 30 minutes or until biscuits are cooked through and top is golden brown. Let stand 15 minutes before serving.
Tips:
If desired, sprinkle 1/2 cup shredded Cheddar cheese (2 oz) on top of biscuit casserole the last 10 minutes of baking.
If you prefer more heat, add 1/2 teaspoon crushed red pepper flakes to sausage gravy mixture.

Tip Top Tips: Make An Easy Calendar In Scribus
Editor's Note: Tip Top Tips is a semi-monthly column in The PCLinuxOS Magazine. Periodically, we will feature -- and possibly even expand upon -- one tip from the PCLinuxOS forum. The magazine will not accept independent tip submissions specifically intended for inclusion in the Tip Top Tips column. Rather, if you have a tip, share it in the PCLinuxOS forum's "Tips & Tricks" section. Your tip just may be selected for publication in The PCLinuxOS Magazine.
This month's tip comes from mutse.
With Scribus, you can design an annual calendar.
Collect, in advance, the necessary and usable photos/images in a separate folder, so that you can quickly find and select them.
Proceed as follows:
Open Scribus. Select new document and choose Cancel.

In the following, empty, window choose the Script menu.

Then select Scribus scripts from the submenu.

Then select Calendar Wizard.
Try it, adjust it, change it, and use the other settings in the wizard.

There's a lot of design pleasure.
Here are some examples:

The top three were made by mutse. The bottom two were made by ms_meme.
Repo Review - Go For It!
by CgBoy
This month I'll be reviewing a to-do list manager called Go For It!.
It has a simple and easy to use interface, with three tabs. On the To-Do tab, you can see all the tasks that haven't been completed. You can change the order of the tasks by dragging them. New tasks can easily be added by typing in the text box at the bottom of the window, and clicking the + button. Checked off tasks will appear in the Done tab, and can be cleared from the menu at the top.

On the Timer tab, you can start a timer for a task. It has a default time setting of 25 minutes, but you can configure it to whatever you want. You can pause and resume the timer, and there's a progress bar at the bottom of the window, indicating how much time has passed. When the timer reaches zero, a break period will start, giving you a chance to rest for a few minutes. The default break time is 5 minutes, but again, you can change it to whatever you want. And when the break period is over, you can start the main task timer again. When you've finished the task, press the Done button and it'll go to the next task.

One of the great things about Go For It! is that it uses the Todo.txt format, which means you can import the tasks into any other to-do list application that supports the Todo.txt format. You can view a list of programs at www.todotxt.org
Summary
So, is Go For It! any good as a to-do list manager? I think so. While it isn't the most advanced one around, I found it to be simple and easy to use. Plus, the timer is a really useful feature.
![]()
GIMP Tutorial: Another Simple Animation
by Meemaw
This one is a very quick and easy method for making a specific animation. I know Valentine's Day is long gone, but the day I did this one was just a few days before Valentine's Day and I had just been playing with some graphics for it, so I used one for this tutorial. This graphic includes a heart design that the very talented ms_meme gave me a few years ago. I added my own text. When we are finished, our animation will be a globe shape, with our selected graphic mapped to the globe and spinning around. (Bear in mind, if you are reading this in the PDF, the globes won't be spinning, but you can open the web-based html version and see the animations.)

Create the graphic you want to use for your globe. Be sure your image is complete before you do anything else to it, and save your work as a GIMP .xcf file. Since the process stretches the image out over the surface of the globe, I made my graphic smaller with a bigger background, on a square canvas 800 x 800 px, as seen below.

When you have your starting graphic complete, go to Filter > Animation > Spinning Globe. A window will appear with some settings. I kept the defaults, except for the number of frames, which I changed from the default of 10 to my desired number of 15.

Click OK and your animation will be made. The more frames you want, the longer it will take as it makes one frame at a time. It will be a separate creation from your beginning graphic. Now you can go to Filter > Animation > Playback to view your animation in GIMP. Clicking on Play will show you what it looks like.

Close the playback window and click Export as... When you put in your filename and choose .gif as the extension, you will get an options window. Make sure you check the box in front of As animation. Click Export.

Now you have a spinning globe that only took a few minutes! I'm sure you can have fun with this.


ms_meme's Nook: How I Love The Sandbox
PCLinuxOS Bonus Recipe Corner

GLUTEN FREE IMPOSSIBLY EASY TACO PIE

INGREDIENTS:
1 lb lean (at least 80%) ground beef
1 medium onion, chopped (1/2 cup)
1 package (1 oz) gluten-free taco seasoning mix
1 can (4.5 oz) gluten-free chopped green chiles, drained
2 eggs
1 cup milk
1/2 cup Bisquick™ Gluten Free mix
3/4 cup shredded Monterey Jack or Cheddar cheese (3 oz)
3/4 cup chopped tomato
1 1/2 cups shredded lettuce, if desired
Salsa, if desired
Gluten-free sour cream, if desired.
DIRECTIONS:
1. Heat oven to 400F. Spray 9-inch glass pie plate with cooking spray. In 10-inch skillet, cook beef and onion over medium heat, stirring occasionally, until beef is brown; drain. Stir in seasoning mix. Spoon into pie plate. Top with chiles. 2. In small bowl, stir eggs, milk and Bisquick mix until blended. Pour into pie plate. 3. Bake about 25 minutes. Top with cheese and tomato; bake 2 to 3 minutes longer or until cheese is melted. Let stand 5 minutes before serving. Serve with lettuce, salsa and sour cream.
TIPS:
Try other toppings like shredded lettuce, sliced green onions, chopped black olives, guacamole or crushed corn chips.
Always read labels to make sure each recipe ingredient is gluten free. Products and ingredient sources can change.

PCLinuxOS Puzzled Partitions
Scrappler


Download Puzzle Solutions Here!
Sudoku

Download Puzzle Solutions Here!
Crossword


Download Puzzle Solutions Here!
WordFind


Download Puzzle Solutions Here!
Cryptograms
From the computer of ms_meme:
Everyday I work the daily crosswords and cryptograms in the paper. I like the cryptograms as they are wise/silly sayings of famous people.
The magazine article about secure passwords made me think of the cryptograms. We have people in the forum who are always posting famous/wise/silly sayings.
I have made a few into cryptograms, and hope our readers will enjoy them.
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