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Welcome From The Chief Editor
'Tis the season to make "New Year's Resolutions." Between 40% and 50% of us will make them. I am not a member of that group, however. The only "resolution" I make every year is to not make a New Year's resolution, and I've been quite successful, every year. It also saves a lot of disappointment.
There will be resolutions to lose weight. There will be resolutions to quit smoking. There will be resolutions to quit drinking alcohol. There will be resolutions to love more, hate less, be less judgemental, be more tolerant, think more, etc. Virtually everything is up for grabs.
Unfortunately, and despite the best of intentions, most resolutions will be nothing more than a distant memory by month's end. In fact, it's estimated that at least 25% of New Year's resolutions will fall by the wayside just one week into the New Year. Nothing quite like starting off the New Year with a broken promise -- to yourself, nonetheless.
If you break your New Year's resolutions, don't despair. You have a lot of company. A 2013 study out of Scranton University (yes, they really do study stuff like this) finds that only 8% of New Year's resolutions are actually kept. That means that of the people who make New Year's resolutions, 92% break them.

The practice of making New Year's resolutions started over 4,000 years ago, with the Babylonians. They celebrated their New Year in March, presumably around Spring. And, it was a festive 11 day celebration. They would make promises to their gods, hoping to receive good favor from their gods throughout the upcoming year.
For most of us -- at least those who make New Year's resolutions (again ... I'm not one of them) -- New Year's resolutions are an opportunity for introspection. That introspection allows us to acknowledge and vow to fix those aspects of our lives that we do not view favorably. It allows us to set personal goals. For many, that introspection is necessary. I, for one, am quite happy with my lot in life. I have "come to terms" with those personal goals that haven't been achieved, and that probably never will be achieved.
The problem is, most people set unrealistic and unattainable goals. In their mind, the goal is attainable. But, in reality, it's no more attainable than being able to walk to Mars. Experts say that you should set realistic and attainable goals. Setting a goal of losing 100 pounds (or even 50 pounds) may not be realistic, but setting a goal to lose 10 pounds by March 1 is a more realistic and attainable goal.
These same experts say to share your resolutions (goals) with others. That way, when your friends, family and acquaintances inquire about your progress, you can give (will want to give) a positive report. Certainly, no one wants to look like a liar, or a failure. No one wants to admit weakness and defeat. No one wants to look like a person who goes back on their word, or that their word isn't worth anything.
I don't know about you, but that sounds a lot like shaming yourself into compliance. Not my cup of tea, thank you very much. I'm not into self flagellation and degradation. Nor am I into setting myself up for failure or humbling myself. Life is already humbling enough with all of its failures, trials and tribulations. It doesn't need my help.
If you are a person who makes New Year's resolutions, I wish you the sincerest best of luck in keeping them. I'll be right there, on the sidelines, cheering you on. But, in so many ways, that introspection causes nothing but extra chaos in an already chaotic world and life.
So, once again this year I will resolve to not make any New Year's resolutions. Until next month, I bid you peace, happiness, serenity and prosperity.

PCLinunxOS Backup Strategies
by Peter Kelly (critter)
According to Wikipedia, it was somebody named Connie Eble who first got the phrase "S**t Happens" into print and, although he never actually said it, Forrest Gump made the phrase famous in the movie that bore his name. Unfortunately though, "it" does happen, so we should be aware of the fact and take suitable precautions.
Large corporations are aware of this and employ many IT professionals to maintain the integrity of their data. Realizing that nothing can be 100% safe, they usually have fall-back plans known as 'Damage limitation Strategies,' which presumably means that they pass on the cost of the foul-ups to their customers.
As home and small system users, we can't do that, so we need to consider just how valuable the data that may be lost, or compromised, actually is. Based on that, we can assess how we can protect the data, and how much effort are we going to put into that protection scheme.
A regular question in the PCLinuxOS forums is 'Which program should I use to create a backup of my system?' This is usually accompanied by 'it must be simple to use and to set up', 'It must be automatic so that I don't have remember to do it', and 'When I have screwed up my system so completely as to make it unusable the program should automatically recover everything'. Now wouldn't that be just dandy?
Unfortunately, no such single program exists but perhaps, using several different applications, we can develop a strategy that comes close to achieving those demands.
Before moving onto the 'how' we must consider 'what', 'when' and 'where'.
What to back up
The obvious answer to this is 'everything,' and my response is no, not everything. Why not? Because there is no point. Your personal data is a must. The home directories of you, and any other users, are also critical. Home directories contain, among other things, all of your personal settings that make your home a home. You don't want to lose all of that. But the system files, no. Restoring those files rarely works as you would expect, and can actually cause some serious problems. A different approach needs to be taken to re-introduce those files, which we will cover later. Before performing a backup, you may want to run a program such as Bleachbit. It will remove accumulated junk, such as temporary files and caches, reducing the size of the backup.
When to do the backup
As often as possible is the ideal answer, as often as practical is more realistic. This takes some thought. On my system, I have my home directory which, as stated above, contains my personal settings and some current 'work in progress' files. I also have a much larger data directory mounted within my home directory. The data directory contains most of the stuff I might need to access, along with my photo, music and video collections. Other files are archived more permanently on remote hard drives. Occasionally, I add files from my home directory to the data directory.
The archives get updated manually, perhaps three or four times a year, as these files are not likely to be needed any time soon (some date back to the 1980's). The files in the home directory and the data directory need to be given a little more attention, and this should be an automatic process. Relying on remembering to do the backup is never a good strategy. My home directory gets backed up daily, and the data directory weekly. This works for me, but only you can determine your own requirements.
Where to keep the backup
There are many reasons why you may require access to backed up files: hardware failure, fire, flood, theft, litigation, etc. From this, it is reasonable to argue that possibly the worst place to have a backup is on the same partition of the same hard drive as the original data. The best place might be on multiple 'black box' flight recorders kept in multiple waterproof, fireproof containers locked in an impenetrable vault guarded by the military and witnessed by at least three high court judges. We will have to settle for something in between.
The media to use really depends upon the quantity of data and the frequency of backups. Floppy disks, once popular are now quite useless for today’s modern data sizes. Optical media such as CD-ROM, are unreliable despite initial claims of indestructibility. Tape drives are frequently used in industry for their large storage capacity but they are expensive, subject to stretch and breakage, and store the data serially. Seeking a single file for restoration is a long, slow process. Solid state storage is convenient and quick, but for frequent backups, its' limited write cycle life span lets it down. Modern hard drives are incredibly cheap and reliable, and have large capacities, so this makes them an attractive proposition. However, hard drives are not infallible, so for more valuable data, multiple copies of the backup should be considered. To avoid the consequences of fire, flood and theft, one copy should be kept 'off-site.' (If the building burns down, then that's bad. If all your records and data get burned in the fire, it's a disaster). Off-site could mean another building or, increasingly popular, cloud storage.
How to do the backup
There are too many 'backup solutions' to name them all, but if you Google around to find out what backup applications other people are using you will find that the name rsync crops up many times. The command line rsync is my own personal favorite, but there are graphical versions such as grsync and luckybackup available from the repositories which simplify its use.
Rsync will keep two data storage areas, a source and a destination, synchronized. The big advantage of rsync over a simple copy is that it will copy over only what has changed. This can mean that the destination gets steadily bigger as newer files are added. So, rsync has an option to delete files on the destination that are no longer on the source -- a true synchronization.
Automatically deleting files from a backup is not always what you want. A week or so down the line and you may regret it, but you can't let the backup grow in size unchecked. The solution that I use is to do five incremental backups using hard links to existing files to save space. Before performing a backup, each of the existing backups are moved up one place with the oldest backup disappearing. This gives me a 'five backup' period of grace. The newest backup always contains at least a link to all available files. Let me demonstrate (skip this part if you are familiar with hard links and file storage).
Example:
I have a directory named src with two files:
ls -lh src
total 1.1M
-rw-r--r-- 2 pete pete 100K Nov 26 14:20 file_a
-rw-r--r-- 2 pete pete 1.0M Nov 26 14:17 file_b
If I copy these files to a directory named dest with the option -l the files will be copied as hard links, which point to the original files.
cp -l src/* dest
ls -lh dest
total 1.1M
-rw-r--r-- 2 pete pete 100K Nov 26 14:20 file_a
-rw-r--r-- 2 pete pete 1.0M Nov 26 14:17 file_b
However, if I issue the command du (disk usage) with the -h option to report human readable sizes, then I see this:
du -h
1.2M ./src
4.0K ./dest
1.2M .
Directory dest is using only 4k of space for 1.1M of files!
The difference between 1.1M reported by ls and 1.2M reported by du is because du reports not file size, but the space used on the drive. Files are stored in blocks of space, usually 512 bytes or 4096 bytes for hard drives, so that a file of even only one byte still requires a full block.
If I delete the original files:
rm -f src/*
ls -lh src
total 0
Then issue the du command:
du -h
4.0K ./src
1.2M ./dest
1.2M .
Now directory dest is the largest. This is because the links still point to the files, which in turn, still take up the same amount of space. What I deleted was the original links to the files, the names under which they were created. A filename is simply a hard link to the file's metadata, and therefore to the file itself. Only when the last link to the file is removed is the file 'deleted.' In fact, at this stage, only the space on disk taken by the file is marked as available, but no data is removed until over-written by a new file. But we no longer have a link to where the file data is stored on the disk.

Applying this to rsync, we can allow the utility to 'delete' files no longer in the source as we still have the links to them in the older backups. Also, as we are only saving links to existing files, we only increase the overall size of the total backup scheme by the size of new files and the minimal size of the links. When one of the older backups is finally removed, we reduce the overall backup size by removing the last remaining links to files removed more than five backups ago.
Using hard links to produce a series of incremental backups can certainly save time and space, but it also has another advantage. If a file is corrupt, then it has changed and the corrupt file is written to the backup. Normally, this would be disastrous, but this can be averted by using the hard link incremental backup system. Yes, the corrupted file is written to the backup, rsync has no way of knowing that the file is corrupt, only that it has changed. However, the previous backups still contain the hard links which point to the original uncorrupted file, which may then be recovered (at least until the oldest backup containing a link to the original file data on the disk has been removed).
The results
The following are the results from backing up my data partition to a USB external drive. This partition currently weighs in at 220GB, with a little over a half million files.
The size of the partition:
# du -sh /home/pete/data/
220G /home/pete/data/
The time taken to perform the backup:
# time data_backup.sh
real 6m6.955s
user 0m5.073s
sys 0m26.040s
Six minutes for a backup over a USB 2.0 interface to a sata-II hard drive is acceptable. The initial backup will take much, much longer than this (probably about two hours with this setup), but subsequent backups record only the changes.
The size of the five backups:
# du -sh data_backup.*
220G data_backup.1
11G data_backup.2
5.7G data_backup.3
3.7G data_backup.4
25G data_backup.5
Backup one reports a size equal to the full contents of the partition, showing that it has links to all of the files. The other backups show additional links to removed files.
265MB total for five backups. Without the use of hard links, this would have been well over a Terabyte. Ten backups would use probably ~ 300MB.
The rsync command
The rsync utility is a terminal command that takes a lot of options to control its power. However, for non-command line users, the graphical front-ends such as grsync and Luckybackup allow you to build up the command from a graphical interface. Here I will show only the command line version as I use it. The following command should be one line only. The backslashes are line continuation markers.
rsync -aAvzHX --progress --stats --delete \
--link-dest=/mnt/backup/data_backup.2/ \
/home/pete/data/ \
/mnt/backup/data_backup.1/
First the options -aAvzHX
| -a | turns on archive mode. You will want this to keep all your permissions, ownerships etc. intact. |
| -A | This preserves access control lists (ACLS), if your system doesn't use them this does no harm. |
| -v | Verbose mode, so you can see what is going on. |
| -z | Compresses the data during transfer, how much benefit you get from this really depends upon the size of files that you are transferring. Modern processors can compress, transmit and decompress a file quicker than transferring an uncompressed file. Compression adds a small header file, so if the files are very small, this actually increases the file size. Usually though this is worth doing. |
| -H | This ensures that files created as hard links on the source are copied as hard links. Without this, the files, when copied back, would not be linked, updating one file would have no effect on the other. This should not be confused with the hard link 'stategy' that we are using. |
| -X | This preserves extended attributes. Few files have these set, but if a file has them, you will want to keep them. |
| Note: the following options, known as long options, are preceded by a double dash. This is not always apparent in printed text. | |
| --progress | Show what is being transferred and how much has completed. This is quite verbose and I use it only while setting up the backup system. Once the system is up and running, it is automatically removed. |
| --stats | prints out a report of what has been done. |
| --delete | delete files no longer on the source. |
| --link-dest=/mnt/backup/data_backup.2/ | |
| This is the option that performs the space-saving trick. It means hard link to files in the stated directory when they are unchanged on the source. | |
Next, we tell rsync the source and destination.
/home/pete/data/
/mnt/backup/data_backup.1/
Do not forget the trailing slash on these last three lines. This is most important.
Using the command
I put the command into a little script that does all of the directory manipulation for me. This is nothing complicated, but you must remember that both the source and destination must be connected and mounted during the backup. If this is a problem you may want to extend the script to automate this, or at least issue a warning.
#!/bin/bash
rm -rf /mnt/backup/data_backup.5
mv /mnt/backup/data_backup.4 /mnt/backup/data_backup.5
mv /mnt/backup/data_backup.3 /mnt/backup/data_backup.4
mv /mnt/backup/data_backup.2 /mnt/backup/data_backup.3
mv /mnt/backup/data_backup.1 /mnt/backup/data_backup.2
rsync -aAvzHX --progress --stats --delete \
--link-dest=/mnt/backup/data_backup.2/ \
/home/pete/data/ \
/mnt/backup/data_backup.1
Running this script updates the series of incremental backups.
Making everything happen according to a schedule
Now we have to automate the entire backup process. We need the data backup to be repeated every week, ideally on a Sunday morning when the computer is running and there is little other traffic. For this, I use the cron system utility. I run all backups as root to avoid any 'permission denied' errors. I covered using cron in issue 57 of The PCLinuxOS Magazine, so I will only show the relevant details here.
In a root terminal enter the command
crontab -e
Unless you have already set up this file, you will be presented with an empty edit window, press "i" to enter insert mode, and then add your entries. Mine looks like this:
SHELL=/bin/bash
PATH=/root/bin:/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=pete
HOME=/root
0 9 * * 6 data_backup.sh
30 9 * * * home_backup.sh
If you refer to the cron article link above, you will find that I have asked cron to run the data backup script at 9:00 a.m. every Saturday, and the home backup every day at 9:30 a.m. These two files are stored in /root/bin, so that becomes the first part of the PATH variable assignment.
Setting up e-mail
The MAILTO variable is set to my own username on this PC so that the output from the scripts will get e-mailed to me for confirmation. This will happen only if internal mail delivery is set up which, by default, it is not. Setting up a simple mail system can be done quite easily. Open synaptic and install postfix, which will also pull in lib64postfix1 as a dependency.
Now you will have to edit two files as root. The files are in the directory /etc/postfix. Open the aliases file and scroll down towards the end where you will see these two lines:
CHANGE THIS LINE to the account of a HUMAN
root postfix
Change postfix to the username of the user who will receive roots e-mail. On this system, this is me. Save the file, and open up main.cf. After the line:
# user configurable parameters
Add the line
myhostname = elysium.localhost
setting it to whatever your hostname is. Save the file and you are done. At this stage, the postfix service is not running, so open up the PCLinuxOS Control Center, and under system > manage system services, find the entry for postfix. Make sure the box 'On boot' is checked, and then click the Start button. Close the control center.
Now check that mail is working. Open a root terminal and type:
mail username
Replace username with the actual users login name. You will be prompted for a subject heading, and then for the body of the text. Press control-d to finish, and you will see EOT (end of transmission). You will then be returned to the command prompt.
mail pete
Subject: mail check
testing...
EOT
Now, open a normal terminal and enter the command mail. You should see something like this (below). Type 1 to read the e-mail, or q to quit mail.
[pete@localhost ~]$ mail
Heirloom mailx version 12.4 7/29/08. Type ? for help.
"/var/spool/mail/pete": 1 message 1 new
>N 1 root Sat Nov 28 10:33 18/608 mail check
? 1
Message 1:
From root@localhost.localdomain Sat Nov 28 10:33:49 2015
Return-Path:
X-Original-To: pete
Delivered-To: pete@localhost.localdomain
Date: Sat, 28 Nov 2015 10:33:49 +0000
To: pete@localhost.localdomain
Subject: mail check
User-Agent: Heirloom mailx 12.4 7/29/08
Content-Type: text/plain; charset=us-ascii
From: root@localhost.localdomain (root)
Status: RO
testing...
? q
Testing the backup system
I would strongly recommend thoroughly testing this setup before trusting your precious files and settings to it. I set up a small directory with a few subdirectories and a scattering of files, set up cron to perform the execution every 10 minutes, and then ensure that both the e-mails are received and the backups correctly performed. Try deleting a file or two, and then recover them by copying them back from the older backups. When you are confident and release the new system for use, watch it carefully over the first cycle of backups. In my case, this means six days for home backups, and six weeks for data backups. Only then can you really trust the system. Remember, a corrupt backup is as bad as no backup.
Recovering the system
PCLinuxOS is a pretty robust system when regularly updated and kept protected from the ravages of its mortal enemy, the user. Even so, there are times when intervention is required.
If you have backed up your data files and personal settings, then the safest route is to reinstall the system from a downloaded ISO, and then to do a full update. After doing this, restoring your backed up files should give you a fully working system as you remember it, but without all of the accumulated cruft that we all seem to accumulate over time.
If you decide to re-install the system but have installed lots of extra applications that you really cannot do without, then I am afraid that you will have to reinstall them. Synaptic can make this task a lot easier by generating a list of all installed applications. Open Synaptic and under the drop down File menu, select 'Save Markings As…'. Type in a suitable name for the list, check the 'Save full state, not only changes' box in the lower left corner, and then save it to somewhere that will not be over-written, like a usb thumb drive. After the re-installation and a full update, in Synaptic select 'Read Markings...' from the File menu. Load up the saved list and click apply. Synaptic will then install everything that is missing. If you don't want all of the files re-installed, you can uncheck them before applying.
MyLiveCD is an excellent utility for capturing a restorable snapshot of your system, and there is now also a graphical user interface to make it even easier. There is a 4GB maximum file size limit, although work is underway to overcome this. I am unsure if this is currently working.
My personal favorite for full partition backups, such as an operating system, is fsarchiver -- which also has a shiny new graphical interface. More than one partition can be put into an archive, making it suitable for full system and data backups. Restoration though is only by a full partition. Individual files cannot be selected, and often with data files it is a single file that gets corrupted or goes mysteriously missing. The fsarchiver utility will also restore the partitions original uuid, which is used by grub to boot the system. This can help to simplify recovery on multi-boot systems.
Conclusion
The perfect backup strategy is a bit of a holy grail, constantly sought but never found. The system outlined here has worked for me over many years and I trust it. I also make copies of the backups and keep one copy off site. Paranoid? Perhaps, but I still have my files after many years.








Get (Download) An Entire Website With wget
by Paul Arnote (parnote)
Have you ever wanted to save/preserve information you found online, but found it too difficult and time consuming to download each page? Or maybe you found it too tedious to print out each page, either on your printer or as a PDF file? Or maybe you needed to backup one of your own websites?
Never fear, because wget can save the day. With wget, we can download an entire website, or just part of a website. I do have to admit that the "inspiration" for this article came from a 2008 Linux Journal article.
CAUTION! Do NOT use this on a very large website, or a website with very large files! You will likely run out of storage space (or at least wonder where a very large chunk of it went). Plus, it's going to take some time to download all those files -- and even longer for the large files. Even a site like The PCLinuxOS Magazine website contains over 2 GiB of data and files. Also, do NOT keep "hammering away" at the same website, over and over again. You may cause unnecessary server traffic, minimally, and you may inhibit others from enjoying the same content. Some content should not be downloaded (e.g. password files, credit card information, etc.), and it's considered "poor ‘net citizenship" to access data and/or content that you normally wouldn't have access to.
So, with those warnings out of the way, let's try to gain a basic understanding of wget and how to use it.
Wget is a command line tool (ah, don't shy away if you're a GUI kind of guy or gal). If you type wget --help into a terminal session, the first thing you'll see is this:
Usage: wget [OPTION]... [URL]...
Then, that is followed by a few thousand (exaggerated) options. Without a doubt, wget has a LOT of options, which illustrates the power of wget. But all of those options are also a bit overwhelming for the new wget user. We won't cover everything you can do with wget in this article. More than anything else, this article is intended to introduce you to wget, and get you discovering how to use it.

So, let's take a look at a wget command. We'll break it all down after you see the entire thing. The entire command is typed on one, single line.
wget -x -r -np -k -v http://pclosmag.com/html/Issues/201511/ -P /home/parnote-toshiba/Downloads/PCLOSMag/
Let's dissect the command. Obviously, we start with the wget command. Next, the -x tells wget to force the creation of directories. The -r tells wget to recursively read all of the directories found under our starting point. Then, the -np option means "no parents," telling wget to not download the contents of directories higher in the directory hierarchy. Next, the -k tells wget to convert the links in the files to work on local storage. The -v turns on verbose output, which gives you a lot more information about the progress of the file downloads.
Then, http://pclosmag.com/html/Issues/201511/ specifies the starting point for our download from the website, and corresponds to the directory on the website that contains the information we want to obtain. On the magazine website, each month's HTML files are in the /html/Issues directory, with each month's files in a subdirectory specified by the four-digit year and two-digit month. Thus, to download the HTML version of the December 2015 issue, you could change 201511 to 201512, and to download the HTML version of the March 2010 issue, you could change 201511 to 201003.
Finally, the -P /home/parnote-toshiba/Downloads/PCLOSMag/ option tells wget where to save the files it downloads. In this case, it is in my /home directory (/home/parnote-toshiba), in the /Downloads directory, in the /PCLOSMag subdirectory. What you enter will depend on properly naming your /home directory, and the location you want to save the files you download.
This command will download almost all of the files that make up the HTML version of the November 2015 issue of The PCLinuxOS Magazine to the directory you specify on your computer. There are files that aren't downloaded, such as the ads that appear in each issue. They reside in a different directory that has been labeled as "off limits" to bulk gathering programs. Those "off limits" directories are specified in the Robots.txt file that is on the magazine website.

Notice the URL address line. Firefox is displaying the local file ... and all the links work, too!
There are some wget command options that aren't compatible with one another. One is the -nc option, which stands for "no-clobber." It isn't compatible with the -k option, which converts all the links so that the offline files work as they should. The "no-clobber" option allows you to pick up where you left off, not overwriting files that have already been downloaded should you become disconnected before retrieving everything. Another is the -O option for specifying a filename for your download (yes, wget can also be used to download single files, too). Again, it isn't compatible with the -k option. I'm sure there are other incompatibilities that I haven't discovered yet.
Of course, given all of the options available for wget, there are some other commands you might also be interested in. First, -D pclosmag.com would tell wget to not follow any links outside of the pclosmag.com domain. Second, -p, the short command for --page-requisites, tells wget to get all the images, CSS style sheets, scripts, etc. necessary to display the HTML page locally on your computer. Third, the -o option allows you to specify a log file for wget to write out to, instead of displaying the information in your terminal screen. Fourth, --user [username] and --password [password] (replacing [username] and [password] with your specific username and password) will pass along the specific field to the website, if you're on a site that requires a username and password. Finally, the -m option will mirror the entire website to your local computer, starting from your specified starting point. You'll be able to get everything except those directories that are marked as off-limits by the Robots.txt file.
Wget is definitely a very handy tool to have in your online tool arsenal. I hope this introduction helps you begin to get a grasp and understanding of the immense power of wget. I urge you to explore some of the many other available options of wget.






ms_meme's New Year's Resolution
Game Zone: Conflicks Revolutionary Space Battles
by daiashi

About The Game
April 1st 1519. A month before his death, Leonardo Da Vinci managed to decrypt ancient Alchemists' secrets and succeeded in transmuting egg yolk into Metamatter, a marvelous substance allowing one to increase intellectual capacities and influence the space-time continuum. The course of history would be changed forever.
With the power of Metamatter unleashed, war broke out and henhouses spread to every corner of the Earth until the planet became too small. As the empires of Earth moved into space to establish even more henhouses on new planets, war followed.
For, in Conflicks: Revolutionary Space Battles, he who possesses the most chickens controls Metamatter and dominates the galaxy!
But while these powerful armies fight for control, innumerable fowl toil in henhouses and dissent brews. Rumor has it that presently even the chickens wish to rise up...
As a general of one of these interstellar empires, you have the power to change the outcome of this war. But will you fight for the glory of your imperial house ... or the redemption of mankind?
The game universe is a futuristic alternate history of the European Renaissance that combines elements from the 16th, 17th and 18th centuries with science fiction and an oddball sense of humor into a stylized, absurdist world that never takes itself too seriously.
Conflicks can be played in a single-player campaign mode where missions are linked together by a story, as well as in multiplayer competitive battles.
Pledge your allegiance to Greater-Britain, the Celestial Empire, the Sacred Alliance or the Sublime Gate and harvest metamatter in the name of your emperor, or join the Chk'Rathii and lead the Revolution against those poultry-hoarding galactic despots!
Main Features
System requirements:
Fully updated PCLinuxOS and Steam
Hardware:
OS: PCLinuxOS
Processor: 2.0 GHz Dual Core
Memory: 4 GB RAM
Graphics: OpenGL 3.0+, 2.1 with ARB extensions acceptable
Network: Broadband Internet connection
Storage: 3 GB available space
About The Company
Located on Montreal's south shore, Artifice Studio is an independent studio specialized in the creation of original videogames. Their focus is clearly on gameplay innovation and immersive universes. Their first game project, Sang-Froid -- Tales of Werewolves, was released on Steam on March 2013 and was critically acclaimed.
Some Gameplay Screenshots





Getting It To Run
Install Steam (if you don't have it installed already), then start it. You will need to create a new account, if you do not already have one. Once you have Steam up and running, go to the store tab. Click on the search box and enter "conflicks" (without the quotes). Click on and download the demo. If you have updated your system, including graphics drivers, you should be good to go.
http://store.steampowered.com/app/419400/?snr=1_7_7_230_150_1


PCLinuxOS Recipe Corner

Cheddar Bacon Chicken Tenders

Ingredients
1 egg
1/2 cup Progresso™ plain panko crispy bread crumbs
1/2 cup finely shredded Cheddar cheese (2 oz)
1 3 oz cooked real bacon bits or pieces
1 package (14 oz) uncooked chicken tenders (not breaded)
Chive and onion sour cream potato topper, if desired
Directions
1. Heat oven to 400ºF. Spray large cookie sheet with cooking spray.
2. In shallow bowl, beat egg. In large resealable food-storage plastic bag, place bread crumbs, cheese and bacon. Dip chicken into egg. Place in bread crumb bag; seal and shake to coat. Place chicken on cookie sheet.
3. Bake 15 to 20 minutes, turning once, until chicken is no longer pink in center and bread crumbs are golden brown. Serve with topper.
Options: use chicken breasts cut into stips instead of chicken tenders. Add garlic, pepper and onion powder for some extra flavor. Serve with sour cream, ranch or honey mustard for dipping.




Get A New Look For Your Multimedia Player: Skin It!
by Paul Arnote (parnote)
Most users are familiar with quartet of multimedia players: VLC, MPlayer, SMPlayer and UMPlayer. They all definitely do a fine job of playing back our multimedia files. But out of the box, their interfaces can become a bit stale and boring. All of them are functional with their default appearance, even if their default appearance(s) are rather boring.
Fortunately, all of them can be "skinned." That means giving them a new look, jazzing things up a bit. Hopefully you can find one that better suits your individual idea of how the interface should look and function.
VLC
Most people will be content using VLC as it is out of the box, so to say, with its default interface.

But, you can make it look however you want. The only way to download the VLC skins are with all of them in a 37 MB ZIP file, containing 120 different skins. If you want to try your hand at creating your own VLC skin, check out this link. You can also download and install the VLC Media Player Skin Editor from here. It is a JAVA application that requires JAVA Runtime 6 or greater (so it should be safe to install to a directory in your /home directory, and run from there), and allows you to create/edit VLC skins without having to know the internal structure of VLC skins.

The above is just one of those 120 skins that are available for VLC. No, it really is not Windows Media Player. Instead, it's VLC skinned to look like Windows Media Player.
Before you can use the VLC skins, you must first extract the skin files to your computer. Under PCLinuxOS, most skins for VLC are in the usr/share/vlc/skins2 directory. Be aware that you will have to switch to the root user in order to place the skins there. Done this way, all of the skins are available to all the users of the computer. However, only one skin may be chosen for all users on the computer.
You can also extract them to --/.local/share/vlc/skins2 (remember that -- specifies a user's /home directory). Done this way, the skins are available only to the particular user who has the skins in the specified directory in their /home directory. However, if every user has this directory in their /home directory, each user may have and use a different skin for VLC.

To use any of the new skins, change the radio button from "Use native style" to the "Use custom skin" setting. Choose the skin you want to use by selecting the "Choose..." button and selecting it from the available skins. Then, select the "Save" button.
MPlayer
There's a LOT to love about MPlayer. It's desktop agnostic. It's free of any of the encumbrances and debate about Qt vs. Gtk vs. anything else. And, when nothing else will play an odd media file, MPlayer is usually there to save the day.

While not totally unattractive, you might just be able to do better. The default MPlayer skin is known simply as "Blue."

The ICY skin (above) is one of many different skins available for MPlayer. Unlike with VLC, you can download each skin separately and individually. Once downloaded, extract the skin file(s) from the archive. If you're so inclined, you can create your own MPlayer skin.
Next, as the root user, copy the extracted (and uncompressed) folders to the /usr/share/mplayer/skins directory. Repeat for as many of the skins as you downloaded, copying each folder to the aforementioned directory.

Right click your mouse in the MPlayer window, and select "Skin browser" from the menu.

Your available MPlayer skins will be listed in the "Skin browser" dialog box. Simply select the one you want to use, then select the "OK" button.
SMPlayer
SMPlayer is a Qt based, MPlayer based program that attempts to make a lightweight multimedia application. It does an admirable job, as SMPlayer has come to my "rescue" several times ... like when nothing else would play an oddball multimedia file and I got bogged down with MPlayer's complexities.
The thought that immediately comes to mind when looking at the default skin for SMPlayer -- to me -- is "utilitarian." Yes, it definitely gets the job done, even if its initial appearance is a bit outdated and tired looking.

By going into SMPlayer's Preferences settings, you can improve on the initial appearance. From the "Options" menu, select "Preferences." Or, select the "Preferences" icon on the toolbar. Or, just press Ctrl + P. Once there, select "Interface" from the selections at the left side of the Preferences dialog box.


Just changing the "Style" setting to GTK+ smooths out the edges a lot for me, especially since I use a Gtk+ based desktop with Xfce.

Under the GUI setting, you can also change from using the "Basic GUI" to using the "Mpc GUI" (shown above). This will make SMPlayer look more like the interface in Media Player Classic (hence, the "mpc"). It definitely cleans things up a lot, too. However, this will seriously limit our ability to further change the look of SMPlayer, so we'll stick with the "Basic GUI." The "Icon Set" setting is largely ignored by the Mpc GUI, except for the time readout in the lower right hand corner. Other choices under the GUI setting are Mini GUI and Skinnable GUI -- of which the latter one is grayed out and unavailable ... at least initially.
You will need to install the SMPlayer skins manually. At this time, they are not in the PCLinuxOS repository. However, not only are they readily available (five skins exist), they are also safe and easy to install yourself. First, download the skins. Then, extract the archive to its own directory. Launch a terminal session as the root user from the themes directory (you can only perform this action as the root user), and issue the following commands:
[root@parnote-toshiba themes]# mkdir /usr/share/smplayer/themes
[root@parnote-toshiba themes]# cp -r ./* /usr/share/smplayer/themes/

Afterwards, select "Skinnable GUI" as the GUI, and then select which of the five skins that you want to use from the dropdown list.

You can also find some new (and quite good) skins and themes in the SMPlayer forum. Many of these skins and themes don't seem to show up anywhere else. In particular, check out the "Artwork and Themes" section of the forum. Another place to look is on the DeviantArt site. Just search for "smplayer skin" ... without the quotes, of course.
Just one note here about SMPlayer's Preference settings. Just hitting "Apply" will definitely apply your changes, but they will NOT "stick around" for the next time you launch SMPlayer. You MUST hit the "OK" button in the Preferences dialog box to make your changes stick the next time you start SMPlayer.
There are some more options available when it comes to customizing SMPlayer. Reset the GUI preference back to Basic GUI, if you have changed it. Then, download the new themes for SMPLayer (you can also install the themes via Synaptic, and skip these next few steps, if you like). Just as with VLC, you must download them all. You cannot download just the ones you want/like, as with MPlayer. Uncompress the archive into its own folder. Open up a root terminal (you must issue these commands as the root user), go to the new folder where you previously uncompressed the archive of SMPlayer themes, and enter the commands below:
[root@parnote-toshiba themes]# mkdir /usr/share/smplayer/themes [root@parnote-toshiba themes]# cp -r ./* /usr/share/smplayer/themes/
(Note: you will only have to do these commands if you have downloaded the theme files and are installing them manually. Also, if you already created the /usr/share/smplayer/themes directory when you installed the skins in the previous step, you can skip the first command.)

The themes are selected from the "Icon set" setting. So, selecting a different icon set will change the icons used with the Basic GUI, and in some cases, it will even make some changes to the window style.

Above is SMPlayer with the H2O theme applied. Notice how not only the icons that SMPlayer uses has changed, but also the color of the window background behind the icons. Most themes don't bother much with the window background color (that I have found), and focus more on changing the appearance of the icon set used.
If you're interested, you can keep abreast of SMPlayer development by visiting the official SMPlayer blog page.
UMPlayer
UMPlayer, for all intents and purposes, is a dead project. However, it does still exist in the PCLinuxOS repository. Below is what appears on the UMPlayer home page:
UMPlayer - The Universal Media Player is an application based on SMPlayer 0.6.9 created by Ori Rejwan, with some extra features like Youtube playback.
But now, the UMPlayer project seems dead (no changes since December 2011). Youtube doesn't work anymore, and some people asked the SMPlayer team to fix UMPlayer. So, we made this release.
However, we recommend to use SMPlayer instead. It includes most of the features in UMPlayer, like support for Youtube and skins, plus some other features that have been recently added and that are not available in UMPlayer. So, if you're an user of UMPlayer, it's highly recommended to migrate to SMPlayer.
Additionally, a similar message is popped up periodically when running UMPlayer.

Hmmm. I think it's so sad when a developer just up and walks away from an open source project. But then, it's not the first time, and it won't be the last time something like this happens.

So, the striking resemblance to SMPlayer is no accident. One nice thing I like about UMPlayer is that it includes five skins when you install it. There's nothing more to install, unless you want a custom skin that isn't provided.

UMPlayer comes with five ready to use skins. In the list above, they are the Black, Gonzo, Mac, Modern and Vista. I added Greybird and Ubuntu_Ambiance. To change the skin, simply open the Preferences dialog box (Ctrl + P, Options > Preferences, or click on the Preferences icon on the icon toolbar), and select the "Interface" category.
You can find additional skins on GNOME-LOOK.org. Going there, I only found two (regular MPlayer skins will NOT work) specifically for UMPlayer. Greybird appears to be the same as the Mac skin. However, the Ubuntu_Ambiance skin appears to be quite nice and unique. You will also find a couple (and only a couple) additional skins on the DeviantArt site. Just search for "umplayer skin" (without the quotes).

Once you download a skin, decompress the archive file into its own directory. Then, open a root terminal (you must perform the following actions as the root user), travel to the parent directory where you extracted the archive file, and issue the following command:
cp -r ./[Name_of_directory] /usr/share/umplayer/themes/
Hence, if the directory where I extracted the Ubuntu Ambiance theme is named Ubuntu_Ambiance, the command will be:
cp -r ./Ubuntu_Ambiance /usr/share/umplayer/themes/
Once you issue the above command for each UMPlayer theme you wish to install, each theme will immediately become available for use.
Despite the common lineage with SMPlayer, it seems to be much simpler to create skins for UMPlayer than it is for SMPlayer. UMPlayer simply uses a CSS file, named main.css, to control the skin ... and roughly 40 specially created image files. Because of its common lineage, I was hopeful that SMPlayer would be able to utilize UMPlayer skins. But no, that would have been too easy. SMPlayer requires the construction of a RCC file that contains all of the icons, and that RCC file is then compiled to make a *.qrc file. Without that compiled *.qrc file, SMPlayer doesn't recognize the UMPlayer skin. Creation of the RCC file, along with the compiled *.qrc file, is above my pay grade ... in a manner of speaking. I've been unable to locate any sort of guide on how to create or compile skins for SMPlayer.
Summary
Now, armed with this information, anyone can tailor their multimedia player experience by applying an already made skin, or making their own.
Now ... who brought the popcorn?



GIMP Tutorial: Convert A Photo To A Sketch
by Meemaw
I found a tutorial that will allow you to change a photo to a sketch. While you wouldn't do this very often, it might be fun for a child to color a picture that means something to him.
Pick out a photo and open it in GIMP. Make it a simple photo, rather than one with loads of detail. I am using a photo of a parade I attended last year.

Navigate to Filters > Edge-Detect > Sobel. Make sure all the checkboxes are selected and hit OK. It looks dreadful, but we have a few more steps.

To highlight the details, go to Colors > Auto > Equalize.

We want a black & white sketch, so we need to get rid of the colors that are left in the photo and convert them to grey. Click on Colors > Desaturate and hit OK.

We are going to create a duplicate layer (Layer > Duplicate Layer, or press Shift+CTRL+D). Let's also name each layer so we don't get confused. Double-click the original layer (the one that doesn't say Copy in the Layers panel) and rename it 'Equalized'. Now double-click the layer you just created (the copy) and rename it 'Adjusted'.
We need to bring out the details of our sketch. This means we will darken the blacks and lighten the whites, so we are going to use the Levels tool that we used in November. Go to Colors > Levels and adjust the Input Level sliders until you're happy with the results. This is one of those times you need to use your own judgement about how it looks, because every photo will need something different. The finished product should look sort of like this:

Another method is to click on Colors > Curves and adjust the curve until it looks the way you want.
We're also going to use a layer mask on this. Make a duplicate of the Equalized layer by selecting it and clicking Layer > Duplicate Layer. Move this layer to the top (with the layer chosen, click the up arrow in the Layers dialog), double-click, and rename it 'Masked'.

We will invert the colors on this new layer. Click on the newly created layer (which should be on top), and select
Colors > Invert.

It is starting to look a bit like a sketch! However, it looks a little grey when we want it to be brighter.
We're going to apply the adjusted layer as a mask. Highlight the Adjusted layer and select Edit > Copy. Now highlight the Masked Layer, right-click, and select Add Layer Mask. In the dialog box that pops up, check the Selection radio button, then press Add. Now, select the Masked Layer you just created and click Edit > Paste. Right-click the 'Floating Selection' layer that appears in the Layer box and click Anchor Layer. It looks kinda weird again, but we'll fix it.

Now, create a new, white layer (Layer > New Layer or click on the New Layer button in the Layers dialog), and place it underneath the Masked Layer. Your sketch should now look similar to the one below.

While the shadows under each truck didn't come out exactly the way I hoped, the trucks themselves look good. I'm sure your project will look great!

PCLinuxOS Family Member Spotlight: Aleph
as told to YouCanToo

What is your name/username?
Luis Orden Ciero
How old are you?
49
Are you married, single?
I am married to Salud since 1992
How about Kids, Grandkids?
A daughter, Salud (22 years old - geologist), and a son Luis 15 years old.
Do you have pets, what is your favorite?
Not now, but I am the uncle of Noita, the dog of my guitarist.
Are you retired, still working and if working, what do you do?
I am Professor of flute at the Superior Conservatory in Seville, Spain. Also, I am a soloist and I play concerts around the world.

Where do you call home? What is it like? IE: weather, scenery
I live in Olivares, a town very near to Seville, Spain. Seville is a typical and touristic Spanish site, very hot in the summer but very, very beautiful and full of history and traditions.
Where did you go to school and what is your education level?
I studied music at the Conservatorio Superior "Manuel Castillo" in Seville. I am a flute Professor.


What kind of things you like doing? hobbies, travel, fishing, camping?
I am very lucky. My hobby is my work, the music. I can play music with friends and travel around the world. Also I like Linux and photography. Now, all my photography workflow is made only with PCLinuxOS (Rawtherapee and Gimp).
Why and when did you start using Linux?
I started Linux in 2010. I hated all the Windows problems and decided to try Lubuntu. After a week, I started with Crunchbang, and after a few months I discovered PCLinuxOS. Since then I have used PCLinuxOS in all my machines as my main OS.
My desktops are IceWM in three installations, Openbox on one, KDE on one, and LXDE (on the notebook of my wife).
More info: www.luisorden.com
I play the flute on these two CDs. You can listen to it on Spotify:
http://open.spotify.com/album/7mBbRgAl1s5BbIxj8via90
http://open.spotify.com/album/4Rdiizyo8dwZodgpLqEup8
PCLinuxOS Family Member Spotlight is an exclusive, monthly column by youcantoo, featuring PCLinuxOS forum members. This column will allow "the rest of us" to get to know our forum family members better, and will give those featured an opportunity to share their PCLinuxOS story with the rest of the world.
If you would like to be featured in PCLinuxOS Family Member Spotlight, please send a private message to youcantoo, parnote or Meemaw in the PCLinuxOS forum expressing your interest.
Tip Top Tips: Fix SlimJet Privacy (It's Tracking You By Default)
Editor's Note: Tip Top Tips is a new monthly column in The PCLinuxOS Magazine. Each month, we will feature -- and possibly even expand upon -- one tip from the PCLinuxOS forum. The magazine will not accept independent tip submissions specifically intended for inclusion in the Tip Top Tips column. Rather, if you have a tip, share it in the PCLinuxOS forum's "{Tips & Tricks" section. Your tip just may be selected for publication in The PCLinuxOS Magazine.
This month's tip comes from PCLinuxOS forum member trytip.
I see in Synaptic these words of encouragement, but they are FALSE.

Slimjet does, in fact, track your every move, just like Google Chrome. The default settings are NOT GOOD, and you need to fix them if you want to use Slimjet and protect your browsing. The first thing to do is enable the adblocker, and customize it with tracking protection lists (choose your language list if it's available. This is the same as adblocker plus for Chrome). Second, move to the privacy section, and select what you see in these snaps.

Below are my settings:


Now delete the contents of the .cache/slimjet directory, and under Slimjet's History/Clear menu, clear your browsing data to start fresh.


ms_meme's Nook: Texstar And Me
Solving Audio Problems With YouTube Videos On PCLinuxOS
by Alessandro Ebersol (Agent Smith)
One of the most annoying things about Linux is having to deal with audio. Yes, despite PulseAudio, which brings more problems and headaches than it is worth, often we install our favorite Linux, PCLinuxOS, on computers with HDMI output and there goes the sound down the drain.
Something does not work, the sound does not come out the browser, or YouTube videos are muted. Then we proceed to use Pulse Audio, and apparently the problems end.
But maybe not, since PA also inserts some problems at the other end. Notably, emulators and other programs that do not work with PA, or Windows programs via Wine are left with horrible sound.

We end up with two choices: Either use PA and have sound in all applications (and horrible sound in Wine and other programs), or we don't use PA, and have good sound in all programs, but muted in some applications (You Tube, for example).
It was a matter of choice, but without being able to have it both ways: Whether one was happy or ate the cake, but to be happy and eat the cake was impossible ...
Until now ...
Yes, you can enable audio in PCLinuxOS, even with HDMI output, so that only the computer's sound card is used, and the sound will not be muted in the browser or other programs, without resorting to PA.
But how? First, let's see how the audio works, and why you don't get audio on "speakers" when there are HDMI devices connected (or built into the chipset).
HDMI: A second sound source
Yes, the HDMI audio output is a second sound source. When the sound is configured, during installation of PCLinuxOS, usually the HDMI output is automatically selected as the default output.
That would be great if it were not tragic. It turns out that this would only make sense if we all had monitors with audio output. Because this feature is common only in TV's, desktop computers setting the standard output to HDMI adapter is useless, causes great frustration, and makes the user to resort to PulseAudio.
But, you can change the default ALSA setting, to point to the computer audio output and forget the HDMI output.
Not very obvious, but not too difficult either.
Asoundrc - The extra sound configuration file.
As listed here, asoundrc is a configuration file which is usually located in the $HOME/.asoundrc directory. For each of the computer users, there is a file asoundrc. This file allows greater control over the sound output, sampling rates and redirecting standard output.
This is the file we will need to modify to change the default ALSA output.
What happens is that during the configuration when the system is installed, the first sound card is identified as the standard output. Often, it is the HDMI sound card.
Changing the Audio Standard Configuration
Now that we know why things are as they are, we will learn how to change this setting that we do not want.
How to do that? Follow the steps below:
1. Identify the sound cards recognized in the system. I'll give the example of the configuration that I work on an HP machine with Intel chipset (sound, graphics and HDMI output).
Open a terminal and type: cat /proc/asound/cards
My result was:
0 [HDMI ]: HDA-Intel - HDA Intel HDMI
HDA Intel HDMI at 0xf7c34000 irq 45
1 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7c30000 irq 46
Two sound cards are recognized. Card “0” is the HDMI output, and card “1” is the regular computer sound card output.
2. Now we have to see how the sound system is configured in .asoundrc file.
Do so in a terminal instance - type cat .asoundrc
My result was:
# playback PCM device: using loopback subdevice 0,0
pcm.amix {
type dmix
ipc_key 219345
slave.pcm "hw:Loopback,2,0"
}
# capture PCM device: using loopback subdevice 0,1
pcm.asnoop {
type dsnoop
ipc_key 219346
slave.pcm "hw:Loopback,0,1"
}
# duplex device combining our PCM devices defined above
pcm.aduplex {
type asym
playback.pcm "amix"
capture.pcm "asnoop"
}
# ------------------------------------------------------
# for jack alsa_in and alsa_out: looped-back signal at other ends
pcm.ploop {
type plug
slave.pcm "hw:Loopback,1,1"
}
pcm.cloop {
type dsnoop
ipc_key 219348
slave.pcm "hw:Loopback,1,0"
}
# ------------------------------------------------------
# default device
pcm.!default {
type plug
slave.pcm "aduplex"
}
Now, we see that the sound output is set to the HDMI output, in the #default device section.
3. Now, with a text editor, open your .asoundrc file and look for the #default device section. Change what is in the file for the following:
# default device
pcm.!default {
type hw
card 1
}
We changed the default audio output, HDMI (card 0) to the computer sound output (card 1).
Now, end your session, logout and login again, and the sound of Firefox browser, Google Chrome and so many other programs will go through the computer's speakers, not the HDMI interface, and there will be no more silence. Ehehehehehe.
Well, some details should be noted:
Finally, disable PulseAudio, which is a dead weight, eating computer processing, when it is so simple to make the change.
Ok?
Further reading:
http://dallarosa.tumblr.com/post/19626256742/fixing-no-sound-in-browser-problem-on-linux
http://www.alsa-project.org/main/index.php/Asoundrc
Update: Our dear “friends” at Google changed the YouTube API, to force HTML5 videos in YouTube. Well, HDMI audio doesn't work well with Firefox; the videos are muted, but it works great in Chrome. Hmmm, that reminds me of MS and its old tricks. To have sound enabled with YouTube playing in Firefox, you have to do one thing now: install an addon in Firefox, called YouTube Flash Player for Firefox, version 1.4.0.
Ok? Install it and you'll have sound again in Firefox YouTube videos, with HDMI capable machines.


Playing Drakensang Online In PCLinuxOS
by Alessandro Ebersol (Agent Smith)

Continuing in the subject of free-to-play MMORPGs in PCLinuxOS, today I'll discuss the game Drakensang Online.
Drakensang Online is an action RPG game in 3D, free to play, that features extraordinary 3D graphics and effects and heralds the next generation of free-to-play online browser games.

With the ability to customize your character, skills and magical powers as never seen before in a browser game, join your comrades to wage a brutal war against evil.

The game world is visually impressive, with picturesque medieval towns, green forests, muddy swamps and dark caves. It was developed by Bigpoint, from Germany, using its in-house engine "Nebula3," impressing players with a level of graphics and 3D effects never before seen in browser games.

Drakensang Online has impressed its fans with a variety of different skills for the characters, exciting and challenging quests, an impressive arsenal of weapons and magic, and over 100 hours of playable content.

The game invites players to take on arms as freedom fighters: Dragonknights, fearless Warriors; Spellweavers, wise and magical; Rangers, archers and hunters and Mechanics, dwarves who use technology as a weapon (in a Steampunk style) to wage a brutal war against the dragons and wild terrible monsters of the Underworld.
Players must join forces and fight as one team in order to survive the treacherous dungeons of Drakensang Online.
Players can meet up in public gathering places, such as cities or military camps, and get to know each other, take on challenges together and create plans to march into battle united. In addition to cooperative gameplay, players can also test their courage against each other in PVP arenas located in the capital of Kingshill, and find out who is the most powerful hero in Drankensang Online.
The game accepts PVE and PVP, and there are specific PVP's servers, where the emphasis is on competitive combat.
Now, how to play this great game in PCLinuxOS?
There is a Play-On-Linux script to install and play Drakensang Online in Linux. However, there is an easy and effective method of playing DRO in PCLinuxOS, without all the extra work of Play-On-Linux.
Before I start with the how-to, however, I will analyze how the DRO client works.
Drakensang Online, a java browser game (said no one ever).
Analyzing how the DRO client works, I came to the following conclusions.
It is a game that runs inside a browser by a Java wrapper, whose function is to call the thinclient.exe program. This a program in C# that is the client running the game.
And I was all happy because I was going to play a Java RPG in my Firefox. How sad when I found out how the game client works. By having a client in C#, win32 does not run on Linux (despite the Java wrapper).
The need for Java means it does not run on Google Chrome browsers as well. But it can be played both in the browser and in PCLinuxOS.
Now follow the cake recipe.
You’re gonna need:
1 - Wine (in repos)
2 - Winetricks (in repos)
3 - Firefox browser for Windows. (https://download.mozilla.org/)
4 - Java virtual machine for Windows(JRE), version 7 (jre-7u80-windows-i586.exe) – Available here.
Now, follow these steps:
,br> 1) In Winetricks, install DirectX 9, as explained here.
2) Now, install the Java virtual machine for Windows, via Wine. Note that it must be that specific version, since it's a version that works 100% with Wine on Linux.
3) Install Firefox for Windows.
And it is ready.
In Wine's Firefox , go to http://agathon.drakensang.com/, register an account, then log into your account. Then, when you get to the player panel, click Play Now, followed by ready. You will be transported to the kingdom of Dracania, to fight the forces of evil, and in PCLinuxOS.
I played this game a lot, and, for best results, it is necessary, in the settings, to lower the quality of the game in fullscreen, play simple shadows and enable good quality for graphics. After some time, the game is laborious to level up the character, especially after level 40, and sometimes the game manifests one "pay-to-win" aspect - very mercenary-like. But it's fun, with great graphics, and it’s good to play with friends and make new friends.
Enjoy yourself playing this awesome RPG in PCLinuxOS!
![]()



Southwest Twice Baked Potatoes
by Ramchu

Add a little zest to your baked potatoes
Ingredients:
4 baking potatoes
1/2 onion, diced
1/2 cup milk
Salt and Pepper to taste
3 tablespoons butter
1 green bell pepper, seeded and diced
1 red bell pepper, seeded and diced
2 jalapeno peppers, seeded and chopped
1 tablespoon minced garlic
2 cups shredded Cheddar cheese
4 tablespoons bacon bits
1/4 cup sour cream
Directions:
Prep 30 min. Cook 15 min. ready 45 min.
Cook potatoes in the microwave until tender enough to pierce with a fork, about 8 minutes. Allow potatoes to cool, then slice in half lengthwise.
Preheat the oven to 350 degrees F.
Scoop out the centers of the potato halves, leaving about 1/4 inch of potato in the skin to keep its shape. Place skins on a greased baking sheet and place the potatoes you scooped out into a bowl. Mash the potato in the bowl with milk, salt, pepper and butter until smooth. Stir in the green and red peppers, jalapeno, garlic and sour cream until evenly distributed. Mound the mixture into the potato skins. Sprinkle cheese and bacon bits over the top.
Bake for 15 minutes, or until the cheese is starting to toast.
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