Welcome From The Chief Editor
Thanks to a poll that Linus Torvalds ran on Google+, the next version of the Linux kernel will be renamed from 3.20 to 4.0. According to Torvalds, it's little more than wanting to keep version numbers low, and that 4.0 will simply be "more of the same." Currently, PCLinuxOS has 3.18.x as the highest version of the Linux kernel.
So, on February 23, 2015, Torvalds released the Linux 4.0-rc1 kernel on Git. In typical Torvalds form, he had some commentary about the poll process in his commit message. And, he was in rare form.
.. after extensive statistical analysis of my G+ polling, I've come to the inescapable conclusion that internet polls are bad. Big surprise. But "Hurr durr I'ma sheep" trounced "I like online polls" by a 62-to-38% margin, in a poll that people weren't even supposed to participate in. Who can argue with solid numbers like that? 5,796 votes from people who can't even follow the most basic directions? In contrast, "v4.0" beat out "v3.20" by a slimmer margin of 56-to-44%, but with a total of 29,110 votes right now. Now, arguably, that vote spread is only about 3,200 votes, which is less than the almost six thousand votes that the "please ignore" poll got, so it could be considered noise. But hey, I asked, so I'll honor the votes. |
So, the 4.0 kernel will be called "Hurr durr I'ma sheep," in obvious reference to the 5,796 individuals who participated in a "poll" that they weren't supposed to participate in. I told you he was in rare form.

In "breaking news" (at the time this column was written), the U.S. FCC (Federal Communications Commission) has put into place strict and rigid rules that prohibit corporate control of the internet in the U.S. Effectively, it eliminates the possibility of the creation of internet "fast lanes," where those who can pay the bounty ... ransom ... er, premium ... can get preferential speeds, while everyone else is relegated to slower speeds. It also prevents ISPs from giving preference to one type/source of data over another type/source of data, effectively known as "throttling." Thus, torrent data and web browsing data are treated the same. This is a HUGE win for internet users across the globe. Since many internet services are hosted in the U.S., users from around the globe will have unfettered and unrestricted access to all of it.
Closer to home for all PCLinuxOS users, Texstar has updated the Xorg Server to version 1.16.4. If you have an older nVidia video card, you may have to change video drivers to work with the new Xorg Server. You can find a complete discussion here. The Intel Mesa drivers have also been updated.
Thankfully, Smileeb has had some response to his pleas for PCLinuxOS users to submit their information and story for the PCLinuxOS Family Member Spotlight column. Please, even if you think no one would be interested in learning more about you, I urge you to participate. Send Smileeb a PM in the forum. He will return your query with specific information on how to be featured in the monthly column. I'd certainly hate to see this regular column go away, just because forum members didn't think they were interesting enough to their PCLinuxOS family. The PCLinuxOS forum really is a family, and we're all eager to get to know more about our fellow forum/family members. Plus, we have a tremendous amount of diversity among forum/family members. It would be nice to highlight that diversity.
Until next month, I bid you peace, happiness, serenity and prosperity.
Gain Control Of Firefox "Flash Is Out Of Date" Message
by Paul Arnote (parnote)
Adobe Flash. What a scourge on computer users. Thanks to Adobe, the creators of Flash, it remains one of the largest security vulnerabilities on anyone's computer. Horrid tales of code jumble are legendary, so much so that there are reports that the code is impossible for any programmer to follow. Certainly, this adds to Flash's security issues. Couple that with Adobe's steadfast refusal to open source Flash (as if they make any money off of it, anyway), this nefarious plugin has made just about every computer user gain new gray hairs and curse its existence.
Most computer users can't wait for the death of Flash, and for it to vanish from the computing landscape. I am among those users. With the arrival of HTML5, Flash's days appear to be numbered, and Adobe will be relegated to -- at best -- a minor, bit player with regards to streaming online content. For me, as well as a lot of other consumers of streaming online content, that day cannot come fast enough or soon enough.
So, for the time being, we are stuck with Flash to play certain streaming online content. But the numbers are shrinking for sites and files that require Flash, as HTML5 gains an ever increasing beach head in the war.

It's because of the ever increasing security vulnerabilities of Flash that we have to endure an almost weekly update of the Flash player plugin. It seems like every week, some hacker discovers yet another new way to exploit yet another security hole in Flash. Since Flash is now (essentially) embedded in Google Chrome, every new security vulnerability that is fixed necessitates yet another update of Google Chrome. Since Adobe stopped officially supporting Linux, I'm not too sure from where the Flash player plugin for the Linux version of Firefox actually comes. But show up it does. And frequently.
Sure, I could just switch to using Google Chrome as my everyday web browser. But I don't like Google Chrome as well as I like Firefox. I've been a Firefox user ever since it was released, and I've grown comfortable and familiar with how it works. I have a bevy of plugins and extensions that I use with Firefox, and they are integral with how I've come to work with Firefox. Chrome doesn't have the same "feel" for me. It certainly doesn't "feel" like home. Plus, a lot of the plugins and added functionality that I've come to depend on in Firefox just aren't available under Chrome, they don't function the same way, or some of their functionality is lost.

When I see the image above, I know that Flash has been updated ... again. So how does Firefox know to "flag" your version of Flash as vulnerable? The answer lies in some new policies and files that are maintained by Firefox.
Starting with version 2.0, Firefox has had settings that allow for the blocking of malicious plugins. Around version 18 or 19, Firefox also added the ability to block vulnerable plugins. By default, Firefox downloads a new "blocklist.xml" file daily. Firefox keeps track of the time by monitoring how many seconds has elapsed since the last daily file update. So, 24 hours equals 86,400 seconds. When 86,400 seconds have elapsed since the last blocklist.xml file download, Firefox downloads a new one. So, that is how Firefox knows whether or not your plugins and extensions are "up to snuff."
In the case of Flash, the annoying message above is displayed on every single website you view that uses Flash. You will have to "Allow" the "outdated" plugin to run on every single site that you visit ... and this gets old, fast. Obviously, the ideal solution is to run updates on your copy of PCLinuxOS. But, if you're not in a position where you can run updates at that moment, or if you typically only run updates weekly or bi-weekly, then one of the following solutions may be more to your liking.

Go ahead and type "about:config" in Firefox's address bar. Click on the "I'll be careful, I promise!" button (and please ... do be careful). Next, type "extensions.block" on the Search line. You should see several entries listed. They are, with the default values in parenthesis:
extensions.blocklist.detailsURL
(https://www.mozilla.org/%LOCALE%/blocklist/)
extensions.blocklist.enabled
(true)
extensions.blocklist.interval
(86400)
extensions.blocklist.itemURL
(https://blocklist.addons.mozilla.org/%LOCALE%/%APP%
/blocked/%blockID%)
extensions.blocklist.level
(2)
extensions.blocklist.pingCountTotal
(user set)
extensions.blocklist.pingCountVersion
(user set)
extensions.blocklist.url
(https://blocklist.addons.mozilla.org/blocklist/3/%APP_ID%
/%APP_VERSION%/%PRODUCT%/%BUILD_ID%/%
BUILD_TARGET%/%LOCALE%/%CHANNEL%/%
OS_VERSION%/%DISTRIBUTION%/%
DISTRIBUTION_VERSION%/%PING_COUNT%/
%TOTAL_PING_COUNT%/%DAYS_SINCE_LAST_PING
%/)
You *could* just disable the blocklist entirely. You *could* set "extensions.blocklist.enabled" setting to "false," or you could change the "extensions.blocklist.url" setting to "" (or NULL). But I wouldn't recommend doing either. By doing so, you prevent Firefox from blocking not only extensions and plugins with vulnerabilities, but you also prevent Firefox from blocking malicious plugins. In short, you could be inviting all kinds of (in)security issues upon yourself. So, this is probably not the best way to go.
You could change how often Firefox downloads the blocklist.xml file. Since the default is 24 hours, or 86,400 seconds, we could change the interval to something longer. Here are some other intervals you might be interested in:
Week (7 days): 604800
2 Weeks (14 days): 1209600
Month (30 days): 2592000
Another choice could be to change the blocklist level. The "extensions.blocklist.level" is set to "2" by default, which means to "hardblock" extensions listed in the blocklist.xml file. By "hardblocking" the extensions, they will not be run unless there is user intervention telling Firefox to go ahead and run/use that extension. Changing the level to "1" should change the blocking level to "softblock." This tells Firefox that the item is in the blocklist, but the problem is not severe enough to warrant forcible blocking.
Still another choice could be to simply delete the blocklist.xml file from your computer (on my computer, it's located at /home/parnote-toshiba/.mozilla/firefox/pwgl1kmj.default/ blocklist.xml). This is useful only until Firefox downloads another copy when 86,400 seconds is up. Still, it can eliminate the nagging about a vulnerable plugin or extension for a little while.
Summary
No one will disagree that Flash is something that most, if not all, of us can't wait to see go away. No one will disagree that Flash is one of the largest security vulnerabilities on the internet, and possibly of all time. Most people will concede these arguments, and agree with you. But since we're strapped with this albatross for the foreseeable future, it would be nice to not have to put up with the constant nagging from Mozilla about yet another vulnerability that has been discovered, which is every time that Adobe issues another update. These days, it seems they only update Flash when another security vulnerability is discovered, and that's proving to be quite often lately.
By all means, keep your PCLinuxOS installation updated regularly. It's the best defense against those security vulnerabilities. But the methods discussed above can keep things running well until you can get around to performing those updates, and help keep the nagging from Mozilla to a minimum.


PCLinuxOS Family Member Spotlight: Xenaflux
As Told To Smileeb
Here is Xenaflux

How old are you?
I will be 70 this coming June.
Married, single or what?
I am married for nearly 25 years now. This is my second marriage.

Children, grandchildren?
Yes, I have three children (with my first wife). One daughter and two sons. They are 50, 48 and 46.
I also have three grandchildren. The first one, a boy and 21 now, with my daughter. The next two, a boy and a girl (nine and three years old) with my youngest son (below).

Retired or working and for how long and at what?
I am officially retired, but carry on working, mainly teaching Thai children (privately) what to do with the knowledge they have picked up in school (as the success rate in school is no more than 15% to 20%; it is all theory and no practice).

Up to two years ago, I was still involved in electronics (occasionally) and home computers (regularly). I stopped that, because it was getting too tiring.
What is the area you live in like. Weather, Quietness, Scenery?
I live North-East of Bangkok, about 60 Km away from the capital. The weather is on the hot side for most people. Temperatures inside the house are 25 to 30 degrees in the cold season, and up to 32 to 36 degrees inside the house in the hot season (all midday measurements). Of course, when the wind blows, or the fans are on, we can get more comfortable. If you can afford the electricity bill, air conditioners are the answer!
As I live now on the end of a two Km long street with only one in/out point, it's very quiet, except when the 56 dogs in this street who seem to have formed a Union, have a concert every now and then. Their favorite concert time is about 1:00 AM.

As far as scenery is concerned,it's not around Bangkok. It’s up North and to the coast....yes!
Are you handy with your hands and have any hobbies?
Yes, I always have been good with my hands, since childhood! Only when heavy machinery is (was) involved, I will (would) call for help. Building a small room, plumbing and that sort of thing I always have done myself. My hobbies have changed from reading and sports to playing the Keyboard (organ). My favorite hobby at the moment is "avoiding sweat."
What is your education level?
I graduated from Technical High school as a Technician in Electronics (no specialization), and got Certificates of "This and That" during my adult working life. I was granted an Engineer's Diploma at the age of 44.
Do you like to travel, go camping?
Not anymore. When I was younger, I visited countries in South America every second year for 2 months, and in between, countries in the south of Africa (I lived that time in Johannesburg, South Africa)
What caused you to try Linux and join this forum?
Some ten years ago, I was using XP, just like a lot of people here. The problem was that I was running/maintaining three or four computers daily. One day, I worked out that over a year I spent about 150 hours on only maintenance/fixing. I decided to try Ubuntu, as they sent the CDs free of charge to your postbox. That was then still a rocky road. I changed to Mandrake and that was better. There at Mandrake was a packager called Texstar, which seemed to have a certain popularity among the members. (I wonder why?) When Tex made his first distro, I tried it and .....the rest is history. I never got involved in Distro-hopping, except on VMs every now and then.
PCLinuxOS Family Member Spotlight is an exclusive, monthly column by smileeb, featuring PCLinuxOS forum members. This column will allow "the rest of us" to get to know our forum family members better, and will give those featured an opportunity to share their PCLinuxOS story with the rest of the world.
If you would like to be featured in PCLinuxOS Family Member Spotlight, please send a private message to smileeb in the PCLinuxOS forum expressing your interest.






Unlock Your Computer With Bash & Your Cell Phone
by John Gagne (zerocool)
(Note: This article uses KDE, but it should be easily adapted for use under other DEs.)
My son is a 1st Lieutenant in the US Army. He was issued a smart ID card and reader which allows him to logon to secure sites. I thought that was pretty cool! The coolest thing I had on my military ID card was a QR code. I've seen other "smart cards," both chip and RFID, thumb drive keys, fingerprint scanners, even face recognition all used for access identification and unlocking privileged computing resources of some kind or another. But it was seeing my son's smart card that got me thinking how to automatically unlock my screen with (what else) my cell phone. Needless to say, I wanted my solution to be even cooler than my son's ID card. And in my humble and totally unbiased opinion, this is way cooler.

Basically, the script pings your local network for your smart phone's IP address and if it's found, unlocks the screen. If it's not found, it locks the screen, instead.
So, why a cell phone? It seems an obvious choice. We all have one and we keep them with us all the time. Where we go, so do our phones. Our phones have become ubiquitous with our immediate presence or absence, and smart enough to make that presence or absence "detectable." When I searched, I found an android app that accomplishes the unlock via bluetooth. I didn't try it for several reasons, not the least of which being that we generally don't keep bluetooth on because it kills the battery. But wifi, on the other hand, we use so much. It's always either on or controlled by the device in sleep mode, but even then it's always listening for the access points it knows (home, work, Starbucks,...) and when these are detected, it automatically connects. So, all we really have to do is teach our computers to accomplish this detection and unlock the screen for us.
So, why use a bash script? Again, It seems an obvious choice. Besides, practicing a little bash kung-fu is never a waste of time! It's extremely powerful and available on all Linux machines.
First we have to do some simple housekeeping on our phones. We need to set a static IP address. You can use any unused address that's outside the scope of your DHCP bank. For most standard home routers, DHCP addresses generally start at 192.168.1.100 and run through at least 192.168.1.150. Generally speaking, any IP between 192.168.1.20 - 192.168.1.90 should be good and if it's not -- odds are you already know what IP address to use. Once you have an IP address in mind, follow this guide to set the static IP address.
For android phones, go to: goo.gl/oMaVvx
For iPhone phones, go to: goo.gl/q1SUTj
Lastly, set your phone's wifi to "stay on when charging". Then when you're using the computer, plug the phone in to charge. That way, the wifi won't shut off in sleep mode and lock your computer screen.
Next, let's perform a little housekeeping on your computer. Create a folder called bash, and then inside the bash folder, create another folder called lock. Then open an editor and copy and paste the following code:


Edit <user_name> with your user name. In my case it would look like:
USER=zerocool
Edit <ip_address of your phone> with the static ip address you set your phone to. In my case it looks like this:
IP_ADD="192.168.1.17"
Notice it's inside quotes.
Edit <welcome message> with the system message to be sent when your phone is detected, in my case it looks like this:
MESS_TXT=" Welcome Cool "
Again, notice it's inside quotes and the starting and ending spaces. Save the file as ~/bash/lock/lock.sh
Next, we want an audible indication of recognition when the computer detects the presence of our phone. I created an mp3 file with an online text to speech engine and then downloaded the file from here:
http://www.fromtexttospeech.com/
Create your own or you can download mine here: goo.gl/uDK6Hv
Save the file as ~/bash/lock/welcome_home.mp3.
Last but not least, open your editor again and paste in the following text:
[Desktop Entry]
Comment[en_US]=
Comment=
Exec=/home/<user_name>/bash/lock/lock.sh&
GenericName[en_US]=
GenericName=
Icon=preferences-desktop-user-password
MimeType=
Name[en_US]=
Name=
Path=/home/<user_name>/bash/lock/
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application
X-DBUS-ServiceName=
X-DBUS-StartupType=
X-KDE-SubstituteUID=false
X-KDE-Username=
Edit <user_name> and save the file as ~bash/lock/lock.desktop. To manually start the script, navigate (via CLI or Dolphin) to ~/bash/lock/ and run lock.desktop. If you want the script to auto start on boot, then also save the file as ~/.kde4/Autostart/lock.desktop.
While it's certainly not Fort Knox with respect to security, if you're like me and didn't use a screen locker at all, this solution is more secure than none. Besides, it's kind of cool to walk in and be greeted by your computer.



Game Zone: Crashed Lander
by daiashi

About The Game
"Outwit gravity, race the clock, explore new worlds."
"Crashed Lander is a gravity-based arcade game inspired by classics like Lunar Lander and Space Taxi. You've built a janky craft out of propane tanks and spare parts. Pilot it from pad to pad trying to beat your best time -- then flirt with that fine line between speed and control.
If you're brave enough to try Hard Mode you'll be flopping around like a QWOPy, low gravity turtle. With a little practice you'll be zippin' around doin' barrel rolls. You'll see sites from the cutting edge of fractal mathematics -- bizarre, organic shapes, arcane archaeological digs, and all manner of WTFderful alien vistas. Each level is a detailed hand-crafted landscape that encourages the player to explore - and goof around! You can also pilot your lander in virtual reality with your Oculus Rift."
* 24 levels to conquer and explore in Pad Hopper mode
* 20 levels in Ring Runner mode - fly through custom courses
* Pad Hopper, Fuel Miser and Ring Runner high scores
* Full Oculus Rift support
* Full (xbox 360) controller support
* Hidden collectibles on every level
* Earn stars and track your progress through all 44 levels
* An hour of spacey, glitch-hop music - mp3's included!
Not a full action packed good guy versus bad guy game, but amusing nevertheless. Hopefully, we will be adding more levels in the future. Maybe an underwater version with environments based on actual data. It's nice to see folks with these talents getting recognized for what they like to do. This is a great time filler. Have not tried it on a flat screen tv as of yet, only on my 20". Should look as equally good though. Well, back to the game. Hope you enjoy it. http://www.brainblinks.com/#/crashed-lander/
System requirements:
Fully updated PCLinuxOS and Steam
Hardware:
Minimum:
OS: PCLinuxOS
Processor: Intel Core i5 or equivalent
Memory: 2 GB RAM
Graphics: NVidia 560ti or equivalent
Hard Drive: 900 MB available space
About The Company
Don Whitaker is a 46 year-old digital tinkerer living in the Willamette Valley of Oregon, USA. He has been making things with computers for over 33 years using every creative tool he can get his hands on. For the last three years he has been using Unity to combine various digital design skills into fun, experimental projects. Don felt like he was ready to launch a full-time game dev career and Crashed Lander is Don's first full-on game.
You can see some of Dons' other game experiments over on BrainBlinks website. Widdly Tinks is a one-finger arcade game, Gravitas is a fun physics toy, and Breeders is a simulation of artificial life.
Some Gameplay Screenshots






Getting It To Run
Install Steam (if you don't have it installed already), then start it. You will need to create a new account, if you do not already have one. Once you have Steam up and running, go to the store tab. Click on the Linux tab if you wish and search for it. Click on and download the demo. If you have updated your system, including graphics drivers, you should be good to go.
http://store.steampowered.com/app/340450/?snr=1_7_tabpaginated__222
Inkscape: Create A Floral Design
by Khadis
Floral or flourishes designs are almost everywhere: name cards (both personal and business name cards), flyers and brochures, banners, or any other printed advertisement media. Floral designs are always attracting me because of the shape and the imagination inside of them. Luckily, I can create any floral shape easily using Inkscape. Let's go!
Open up your Inkscape as usual. Prepare your paper as you desire because the size of the paper will not matter. Before we really start to draw the flourishes, basically, there are two methods: complex and easy. Now, I will show you the first method, the complex one.





That is the first method. The second method will be much easier because you do not need to prepare any shape, but directly draw your flourish using the Bezier tool.




Tic, Toc, Tic, Toc... It's About Time
by Paul Arnote (parnote)
Time. It's at the core of nearly everything we do. Our lives center around it. Our lives are defined and dominated by it. We use time to measure nearly everything. Our work week. How fast our computers boot. When to eat. When to sleep. When to wake. When to go to work. When to take a break. Birth. Death.
With something so integral to our existence, it's no wonder that there are people whose job it is to fret, worry over, "manage," and monitor time. They are the planet's "timekeepers," if you will. If you're like me, you may think that these individuals have way too much of what they are given stewardship over.
Since 1972, they have periodically been inserting "leap seconds" to our clock to "compensate" for irregularities in the Earth's orbit. These "irregularities" render the atomic clocks "too accurate," and astronomical time (based on the Earth's orbit, with all of its irregularities) and "atomic time" will no longer perfectly sync up. In an oversimplified way, UTC time (also known as Coordinated Universal Time) relies on the time as reported by the atomic clocks. Believe me ... this whole time business is complicated. You can find a reasonable, albeit complex, explanation here. Be prepared to jump around on that site to get a complete picture of all the complexities involved.

Herein lies the problem. The leap second is added to prevent the eventual drifting of GMT (Greenwich Mean Time) westward, according to the atomic clocks. Many computer systems -- including Linux -- synchronize their clocks with UTC time. To be fair, Linux synchronizes its clock with NTP (Network Time Protocol), which utilizes UTC time.
I don't know about you, but I hardly see this as a crisis, or even a problem that needs to be fixed. The Earth has been here for over 4,540,000,000 years (yes, BILLION), complete with all of its orbital irregularities. The fact that our atomic clocks are too accurate hardly seems cause for disturbing something that has been going on since the Big Bang: time, as we have come to know it. Sunrises occur every morning, sunsets occur every evening. In fact, it was never a problem until we -- mankind -- came up with a timepiece (atomic clocks) that did not take into account the irregularities of the Earth's orbit. So, in a way, WE manufactured this problem.
This coming June 30, they will once again add another "leap second" to the official clock. At midnight on June 30, the leap second will be added right after 11:59:59 (p.m.). During that brief second, the clock will read 11:59:60, as they add the additional second to the clock. This will mark the 11th time that a leap second has been added on June 30, since 1972. This joins the 15 times that a leap second has been added on December 31, for a total of 26 leap seconds that have been added to our clocks since 1972. In fact, a leap second is added to UTC time on average of every 18 months, give or take (depending on those orbital irregularities of Earth).
Sounds like a fairly simple proposition, huh? But wait ... there's more.
Back in June 2012, the addition of the leap second brought many popular websites down. We're talking about sites like Reddit, Amazon Cloud, Gawker Media, and Mozilla, among others. A "glitch" in the Linux kernel was the cause. More specifically, the Linux kernel has a function/subsystem called "hrtimer," short for high resolution timer. It (or programs that have a strong reliance on hrtimer) simply couldn't handle the addition of the leap second, causing it to consume large amounts of CPU time as it tried to reconcile the time difference. In the end, so much CPU time was consumed that it effectively locked those computers up. The problem was resolved simply by rebooting the affected machines.
While the average user probably hardly noticed, it affected many servers running Linux. See, Linux -- more specifically hrtimer -- syncs via NTP, which utilizes UTC time. The discrepancy between hrtimer and UTC time was more than it, or programs that depend on hrtimer, could handle. The "glitch" had been patched in March 2012, but not everyone had applied the update. Those who hadn't were the ones adversely affected.
So, what's in store for the June 2015 leap second? Well, according to Linus Torvalds, it shouldn't be anything to worry about. In the intervening three years since the last leap second, most if not all of the servers have updated their kernel and kernel subsystems. Additionally, a lot of the software that depends on NTP/UTC has also been updated. Torvalds expects the problems to be minimal, and expects nothing even remotely close to the problems experienced in June 2012.
Still, someone, somewhere is bound to experience a problem. According to Torvalds, the leap second is a rare and infrequent event. While the testers may test under one set of circumstances, there's no guarantee that a new circumstance that was not previously thought of won't crop up. And, because the addition of a leap second is such a rare and infrequent event, it's not something that kernel testers routinely check.
Tic, toc, tic, toc ... it's ALL about time.

ms_meme's Nook: Download Me
PCLinuxOS Recipe Corner

Baked Teriyaki Chicken
This month's recipe comes from the PCLinuxOS forum user Ramchu.

INGREDIENTS:
2 Tbsp Cornstarch
2 Tbsp Cold Water
3/4 Cup White Granulated Sugar
1/2 Cup Soy Sauce
3 Tbsp Cider Vinegar
1 Tsp Garlic Powder
1/2 Tsp Ground Ginger
1/2 Tsp Ground Black Pepper
10 Chicken Thighs or 6 Chicken Breasts
DIRECTIONS:
1. In a small saucepan over low heat, combine the cornstarch, cold water, sugar, soy sauce, vinegar, garlic, ginger and black pepper. Let simmer, stirring frequently, until sauce thickens and bubbles.
2. Preheat oven to 425 degrees F (220 degrees C).
3. Place chicken pieces in a lightly greased 9x13 inch baking dish. Brush chicken with the sauce. Turn pieces over and brush again.
4. Bake in the preheated oven for 30 minutes. Turn pieces over, and bake for another 30 minutes, until no longer pink and juices run clear. Brush with sauce every 10 minutes during cooking.
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h3>GIMP Tutorial: Creating A Swirl Effect
by Meemaw
We've done backgrounds before, but we will use GIMP this time to create a swirled background. This was a fun tutorial to do, as well.
Open a new image (File > New) in the size you want. I used 1600 x 1200, but you can use bigger if you need it.
Decide on a color and then choose two shades of that color so we can put in a bit of a gradient. My favorite wallpaper color is blue so I used two different shades of blue.
Click on the Blend tool in the Toolbox and verify that the Gradient is set to FG to BG and the Shape set to Linear. With the Blend tool, draw a line from the top to bottom, bottom to top, or from corner to corner. I drew mine from top left to bottom right, and as you can see, the top left corner is darker.

Change the foreground to white, then draw a swirl in the middle of your image using the brush tool. The the swirl won't be perfectly uniform, unless you draw much better than I do!

Click on Filters > Blur > Gaussian Blur and set both values to 40, then click OK. You should have an image that looks sort of like this:

Now, click on Filters > Distorts > Whirl and Pinch. Move the Whirl angle slider all the way to the right (the number will be 720), the Pinch amount slider about three-quarters to the left (around -0.5) and leave the radius at 1.00.

Let's adjust. Click Filters > Distorts > Waves. Make sure that the Smear radio button is selected. Play around with the amplitude, phase, and wavelength sliders until you're happy with the result (as you can see below, I set the amplitude to 70, phase to 145, and wavelength to 45).

Before we finish, we want to make the ripple effect stand out a bit more. Go to Filters > Artistic > Softglow and adjust the sliders to your liking. I set the Glow radius to 1.00 (all the way to the left), Brightness to 0.25, and Sharpness to 1.00 (all the way to the right).

We are finished, unless you want to go back and adjust something else. You can always go back into any of the Filters items and change settings. If you decide the color is wrong, instead of starting over, click on Colors > Hue-Saturation and adjust the Hue slider.

You can always play around with the other filters and see what different effects you can come up with. One option is Filters > Render > Clouds > Difference-Clouds. I changed the color of my original to a shade of green (in Colors > Hue-Saturation), then did the Difference-Clouds filter with the X and Y sizes set to 1. Experiment all you want!
ScreenShot Showcase

Posted by Aleph, February 1, 2015, running icewm

Posted by Hertz, February 3, 2015, running LXDE

Posted by Meemaw, February 12, 2015, running Xfce

Posted by nymira, February 23, 2015, running Mate

Posted by OnlyHuman, February 16, 2015, running e17

Posted by Roc4fun, February 1, 2015, running KDE

Posted bytbschommer , February 14, 2015, running KDE

Posted by weirdwolf, February 8, 2015, running LXDE

Posted by Yankee, February 9, 2015, running Openbox

Posted by zerocool, February 8, 2015, running KDE