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Welcome From The Chief Editor
Want to know something? Surgery sucks.
OK, so that's no huge revelation. The only other surgery (where I've been put under general anesthesia) I've ever had was a tonsillectomy and adenoidectomy -- back when I was 19 years old.
Fast forward almost 35 years. On July 9, I had to undergo another surgery. Back in June, I was sitting in my recliner with one of my laptops in my lap. I typically use the quiet hours of the morning, before my wife and son wake up, to get go through my overnight email and work on magazine "stuff." Nothing too unusual about that. But on that particular morning, I discovered that my left knee was swollen. I hadn't done anything to injure it. It's as if it just swelled up on me, right then and there.
I tried to stand. Man, did my knee hurt!
I nursed my knee along throughout the day, but the swelling persisted. That evening, I put an ice pack on my knee, without the desired results of reducing the swelling. I took off sick for a few days from work, thinking that if I could stay off of my inflamed knee that it would get better. Indeed, a few days later (over Father's Day, nonetheless), it seemed to be improving. So, back to work I trudged, still nursing my tender, but improving, knee.

Mind you, I'm on my feet at the hospital nearly all day long. As you might imagine, that did no favors for my knee. After a couple of days, my left foot and ankle started exhibiting some swelling, called edema. THAT really got my attention. It got my attention enough to send me to the Emergency Room of the hospital that I work at. The edema got me worried that I might have a blood clot in my leg (called a deep vein thrombosis) that was impeding blood flow.
Come to find out, fortunately, there was no blood clot. Instead, I had what was called septic bursitis. Septic means an infection, and bursitis is the inflammation of the bursa. The bursa holds the "lubricating fluid" for the various joints in your body. They referred me to an orthopedic surgeon.
Two 10 day courses of antibiotics failed to resolve the situation, so the surgeon scheduled me for a bursectomy to remove the inflamed and infected bursa in my left knee. Now this isn't a huge or complicated surgery. But, it's surgery nonetheless. It is a surgery that required me to be put under general anesthesia.
He performed the surgery at the outpatient ambulatory surgery center. I even walked out of the surgery center under my own power. With the surgery performed on a Wednesday, and being scheduled to work Thursday and Friday, I only missed a couple of days of work. I returned to work the following Monday.
Now (at the time that I am writing this) it has been nearly three weeks. The surgical incision on my left knee is almost completely healed. The edema in my left ankle and foot has almost completely disappeared. Still -- surgery sucks.
To put July even more into the "suck" column, I had to have my 14 year old cat, Buddie, put to sleep. He lost his battle with lymphoma. We (me and my wife) do feel fortunate to have had him around us for an additional seven months after they made the original diagnosis. They originally said he only had weeks to live, because the form of lymphoma he had was very aggressive. He was in a few pictures in this column over the time that I've been the magazine's chief editor. Cats are a lot like people, and each one has a very unique personality. Buddie always thought he was a four legged human with a fur coat. He thought people came here to see him. He never met a stranger. We miss him terribly.
Until next month, I bid you peace, happiness, serenity and prosperity.
Templates: Google Docs Best "Hidden" Feature
by Paul Arnote (parnote)
Psssst! I bet you didn't know about the vast quantity of templates that exist for Google Docs/Google Drive. Don't feel alone. I didn't either, despite having used Google Docs regularly for the past five years. Here at The PCLinuxOS Magazine, we use Google Docs to share the magazine's articles among the staff, and to facilitate collaborative editing of those articles. It wasn't until the past month or so that I discovered the vast quantity of templates that exist for Google Docs. To say that I was blown away would be an understatement.
Don't expect the available templates -- many uploaded by other Google Docs users -- to be arranged or sorted into any kind of logical order. It appears that some users just upload them to the first category that they stumble across, without regard to how well it fits into the selected category. Thankfully, you can also view templates by what type of file they are (document, spreadsheet, presentation, etc.). Still, the quantity of available templates is overwhelming.
Here's a brief breakdown of the categories of Google Docs templates:
| All categories Albums & Flipbooks Business Calculators Calendars & Schedules Cards & Certificates Holiday Labels & Business Cards Letters & Faxes Miscellaneous Personal Finance Presentation Designs Resumes & Cover Letters Statistics Students & Teachers |
The best word that can be used to describe the sorting of available templates into categories is "unmoderated." That is, there is no one responsible to insure that the uploaded templates are placed into the appropriate category. They tend to lie where they land -- or in the category into which the uploader places them. This can make it difficult to find templates that might be useful to other users, including ones that might be useful to you.
Still, there are some pretty useful templates available for your use, if you can locate them. Looking to make a new resume and cover letter for a renewed job search? Chances are high that you'll find something that suits your needs. Looking to track your household expenses and develop a household budget? Plenty of those types of templates exist. Need to create an invoice for a new or existing business? No problem. Those templates exist, too. Want to make your own custom greeting cards? It's easy, using one of the templates. Need to create mailing labels to mail out your newly created greeting cards? Find the template that matches the labels you have (or buy).
Gaining Access To The Templates
Whether you are connected to Google Docs or Google Drive, the procedure is exactly the same.

From the "Create" button, select "Connect more apps" at the bottom of the menu.

In the dialog box that appears, find and select the "Drive Template Gallery." If you don't see it listed, enter "template" (without the quotes) into the search field, as I've done in the image above. The app add-on should be listed at or near the top of the list. Select the "Connect" button to the right of the add-on.

Select the "Accept" button in the permissions dialog box.

Now, select "From Template" in the Google Docs/Drive "Create" menu.

Search for -- and hopefully, find -- the template you want to use. From that point on, it should be simply a matter of applying the template to your needs.
If you can't find exactly what you are looking for among the thousands of available templates, there's certainly nothing stopping you from finding one that comes close and tailoring it to your personal needs and/or tastes.

![]()

Inkscape Tutorial: Holiday Wallpaper
by Meemaw
It's early yet, but most of us like to celebrate some sort of winter holiday. If you like to put up decorations and send cards, you might have fun with this project, and we're doing it early enough that you can practice. I send Christmas cards every year. I saw something with a snowman/snowball theme, so I thought I would try it for my cards. It would also make a nice holiday wallpaper. We can make a snowman or decorative balls. These look like they were made from wire.

Open Inkscape, and start by making a circle. Using your bezier tool, draw many lines across your circle to make it look like it is made of wire. Using Path > Object to Path on each line, select your Nodes tool and put a little curve in each of your lines.

When you have it the way you want it, select all lines and the circle by drawing a box around them with your cursor, and then Group them. Change the color to a light grey.

With your group selected, click on Filters > Bevels > Glowing Metal. Your group will turn a shiny silver color.

You can also make them different colors! I have found that you need to use a lighter color to start, because the glowing metal filter will darken the color somewhat. You will probably have to experiment with the colors to get what you want. With this one I used a pink, but the glowing metal filter made it a bit darker.

I used the colored ones for the decorative balls, and the silver ones for the snowman, duplicating, resizing and rotating the first circle and then stacking them.
For the ball hangers, I drew a square with a linear gradient fill, grey and white, to give it some highlight. I kept a very thin dark grey stroke to define the shape a bit. Choosing Path > Object to Path, I added two nodes to one side of the square, and then moved things around until it was narrower at the top with a scalloped edge at the bottom, like many of those hangers have. Then, I made a circle (no fill and 5 px stroke with a grey to white gradient) and covered a little over half of it with a rectangle. I then chose Object > Clip > Set to only use part of the circle. Rotating them into position, I combined the two shapes for a ball hanger, grouped them and placed them on the edges of the wire balls.


If you want, you can create colored stars, make them shiny with the glowing metal filter and place them on the wire balls, as shown at the beginning of this article..
The snowman requires a bit more work. Most of it is creating the desired shapes (coal pieces for eyes, mouth, and buttons, a triangle for the nose, lines for arms, and irregular rectangles for the scarf). I used black hexagons for the eyes, mouth and buttons, pulling the nodes on the eyes and mouth so they look like irregular pieces of coal. The nose was an orange triangle with the nodes pulled on it to make it irregular. The scarf is three red rectangles that I made irregular and merged with Path > Union. The nose, buttons, arms and scarf were also made metallic with the Glowing Metal filter that we used on the wire circles. The eyes, mouth and mittens are black with a white blur to highlight them a bit. The hat is done the same way as the wire circles. I drew three rectangles, different sizes, to represent the top brim and band of the hat. The top and brim were done with the wire-look, and the band was filled with a solid color. When I had them done, I grouped them and then used the glowing metal filter.
When you get them all finished and arranged as you want them, group and export your selection. If you want something moved, just ungroup them and make your change, then regroup them. There will be two versions of my snowman because I moved one of his arms.
Here is my snowman, but yours will probably look different:

After that, you can use Inkscape to create a holiday wallpaper or greeting cards from either of your creations.


PCLinuxOS Recipe Corner

Grilled Flank Steak
Ingredients
3 lb flank steaks
1/3 cup white-wine vinegar
3/4 cup olive oil
1 1/2 tablespoons minced fresh rosemary
3 garlic cloves, minced
2 teaspoons salt
1 teaspoon black pepper
Preparation
Lightly pierce steaks all over with a sharp fork or knife. Whisk together remaining ingredients and transfer to a large resealable heavy-duty plastic bag. Add steaks and seal, pressing out excess air. Marinate steaks at least 6 hours or up to 1 day.
Prepare grill for cooking.
Grill steaks on an oiled rack set 5 to 6 inches over glowing coals, turning once, about 12 minutes for medium-rare. Transfer to a cutting board and let stand 5 minutes. Thinly slice steaks diagonally across the grain to serve.


ms_meme's Nook: Oh, Look At Me Now
Extend LibreOffice Capabilities With Extensions
by Paul Arnote (parnote)
There is no denying that LibreOffice is one of the premiere office suites available. Its capabilities are sweetened by its price: FREE. LibreOffice, all by itself, is a powerful office suite, right out of the box. But you can make it even more powerful by adding extensions to LibreOffice.
Extensions work to add features that the developers have omitted from the core office suite, or that enhance or replace the current features of LibreOffice. You can view all of the available extensions for LibreOffice here. Once there, you can view every extension available, or you can view extensions related to individual LibreOffice components. Overall, there are 225 extensions available for LibreOffice. Viewing the extensions for each individual LibreOffice component makes the job of finding the appropriate extension much easier, and a lot less overwhelming.
For example, searching under the "Writer-Extensions" category, it separates out all of the extensions available for LibreOffice Writer, and makes finding extensions that specifically work with Writer much easier to find.
While looking there, under the "Writer-Extensions" category, you should take a special look at the Language Tool extension. This extension helps check your documents for proper style and grammar, and works for 29 different languages. Of course, the level of support for each of the 29 languages may differ, but it will help you detect the improper use of homonyms, such as your/you're, they're/there/their, to/too/two, see/sea and so forth (at least in the English language, which is the only one I'm fluent in).
Another useful extension allows you to import and export documents, spreadsheets and presentations, to and from Google Docs, Zoho Office and WebDAV. Yet another, called MultiSave, allows you to save your Writer documents in the OpenDocument ODT format, the Microsoft DOC format, and as a PDF file, simultaneously when you save your document -- instead of having to save it multiple times, once in each format.
Some other categories include different graphics libraries you can load into the LibreOffice graphics gallery. Of course, there are separate categories for LibreOffice Calc, Writer, Impress and Draw.
Installing LibreOffice Extensions
Once you find an extension you want to use, you will need to install it. First, since most of the extensions are written using Java, you will have to insure that Java is installed on your computer, and active for LibreOffice.

Under LibreOffice's Tools > Options menu, go to the "Advanced" settings. Make sure that the "Use a Java runtime environment" checkbox is checked, then make sure to select the version of Java that you want to use in the center part of the screen. Next, select OK. You will receive a notification that LibreOffice will need to be restarted.
Now, go to the LibreOffice Extensions page, and download the extensions you want to install and use. I recommend saving the extensions in their own directory, just to keep things nice and neat. I created a directory in my /home directory, called LO-Ext, and I place the extensions there when I download them.

Once again from the LibreOffice Tools menu, select the Extension Manager… menu item.

Select the "Add…" button, then select the extension that you downloaded. You may have to select the extension in the list, after you have added it. You may also have to enable your new extension. Some extensions are automatically enabled, while others require you to deliberately enable them.
At this point, it's highly recommended that you exit and restart LibreOffice again. I've found that restarting LibreOffice after installing extensions makes it function much more reliably.

The image above shows the Google Docs & Zoho extension menu item (under the File menu), after restarting LibreOffice Writer. Trust me … it wasn't displayed until AFTER I restarted LibreOffice Writer.
Caveats
You will notice that some of the extensions will list compatibility with only a few older versions of LibreOffice. Going to the web page for those particular extensions also displays a "warning" that the extension hasn't been updated in over a year. Most of the time, you can ignore the warnings and the limited "compatibility" statements. For example, the Google Docs extension works perfectly fine on LibreOffice 3.6 and 4.1, despite being listed as compatible with only versions 3.3 and 3.4. It's as if no one is checking/maintaining compatibility testing, and using the creation date as the only criteria for determining functionality and version compatibility. Unless Google Docs makes some radical changes to how it accepts uploaded documents, it's unlikely that there is a need to update the extension -- hence, the reason for no updates in the past year.
Your mileage may vary, but I seriously doubt it. While I've not installed every extension that's available, every extension that I have downloaded works on every relatively modern version of LibreOffice that I tried it on. This is without regard to the bogus "compatibility" statement, or the erroneous caution statement based on its last "update" date.
Still, LibreOffice extensions can add some useful features to an already powerful office suite (probably the most powerful office suite available, in my opinion).


Cool Add-ins For LibreOffice & OpenOffice
By Khadis
It's an undeniable fact that Linux users vary from different homelands, different education and professional backgrounds, different cultures, different age, and even different gender. Linux users are using Linux tools and software for many activities, based on their needs and their background.
As two "common" software titles that are used by millions of people around the world, LibreOffice and OpenOffice are known to have thousands of helpful add-ins that will make our daily use much more easier and increase our productivity.
The following LibreOffice and OpenOffice add-ins may meet your needs for special purposes.
Qur'an in OpenOffice (QiOO)

QiOO was developed as a "copy" of the same add-in for MS Office Word, called Qur'an in Word. The main function of this add-in is to insert surah and/or verses of the Qur'an (the Koran) and their translation. Although its name is Qur'an in OpenOffice, it can also be installed in LibreOffice.
Unlike the Ms. Office version that can be installed by double-clicking the executable file, QiOO has its own method to be installed to your LibreOffice/OpenOffice. Here are the ways to install it:
First, download the installation package, then extract the all files to a directory, e.g. Documents. Install ScheherazadeRegOT.ttf font that is already included in the package by double-clicking on it.
Second, access the Tool > Extension Manager menu and click on the "Add" button to find out the location of your extracted add-in. Find out the QiOO-xxx.oxt file.
Third, after the QiOO is installed, restart LibreOffice/OpenOffice. After that, activate CTL (Complex Text Layout) from the Tools > Option > Language Settings > Languages > Enable for CTL (Complex Text Layout) menu.
Automatically, you'll find AlQuran menu on your toolbar. QiOO is installed ready to be used. Now, you can insert any surah and or verses, plus their translation (if needed) as easy as clicking on the name of surah and the number of verse.
For more Information, check out this website: http://code.google.com/p/qioo/downloads/list The file is a 728 KB free download.
Anaphraseus, a CAT tool

CAT, or Computer Aided Translation, is a tool that will help translators to translate their works by splitting paragraph/documents into smaller segments to make them easier to be translated. Actually, there are so many premium CAT tools that MUST be owned by professional translators. Unfortunately, the price is so expensive and mostly run under Windows.
Luckily, if you are new in the translation field, you can always rely on Anaphraseus to translate LibreOffice's/OpenOffice's supported files. Unlike any other stand-alone CAT tools, Anaphrasesus is planted into LibreOffice and OpenOffice as add-in.
Anaphraseus can be installed through the Tool > Extension Manager menu. Then, click on the "Add" button and point to the directory where you saved this add-on. Later, in the Extensions Software License Agreement window that appears, scroll down until the Accept button is on. Click that Accept button and restart your copy of LibreOffice/OpenOffice.
Using Anaphraseus is easy. Just open the document that you want to translate and click on Start Session button on your toolbar. You can always choose Setup to create new TM (Translation Memory). This TM will make your next translation projects much easier and faster, by auto-translating the same words, phrases, or even the same sentences inside the document. So, you won't need to do copy-paste or re-write them repeatedly. Next, to start translating, click on Translate icon and use Alt - Down Arrow to move to the next segments.
The only "bad side" of this add-on is that Anaphraseus can only help us to translate OpenOffice/LibreOffice supported file formats as it is running as an add-on for OpenOffice/LibreOffice. If you have other file formats that need to be translated, I suggest you to use OmegaT.
For more information, check out this site: http://sourceforge.net/projects/anaphraseus/ The file is a 249 KB free download.
Mathematic Add-ins

Occasionally in your life, you might need to write a complex math formula, create 2D or 3D objects, create a curve, or any other math objects. If so, then you need to install at least the following 2 math add-ins. Dmaths and iMath. Like other add-ins for LibreOffice/OpenOffice, they can be installed through the Tools > Extension Manager menu.
After installing them, a new toolbar will appear in your LibreOffice/OpenOffice. By using iMath, you can insert any mathematical function into your document.
While by using Dmaths, you can create 2D flat figures and 3D geometrical objects. You can put labels on each corner point (vertex), diagonal line, and even to make nets (e.g. cube net) But please note that Dmaths has components on its toolbar called Gdmath that is shown in German. If you don't know German, it will little bit hard to understand how to use this toolbar.
For more information, check out this site: http://extensions.libreoffice.org/extension-center/ The files, both free downloads, are 12.3 MB (dMaths) and 2.03 MB (iMath).
Programming With Gtkdialog, Part Five
by Peter Kelly (critter)
The Notebook Widget
We've all seen this widget, or something similar, in action in some of the major applications, such as web browsers. We use notebooks on a daily basis, even if we didn't know that they were called notebooks. Now gtkdialog makes a similar feature available for us to use in our own applications. A notebook widget is a dialog with tabbed pages and each can be populated with other widgets.

Here's an example of its use, a five page photo album. While the photo album is of little use, it can be used as a template to construct something more practical by replacing the pixmap and text widgets on each page, and by adjusting the number and names of each tab.
The code:



Setting up the notebook widget is much like many of the other widgets I have shown. The tab-labels attribute, if omitted, defaults to Page 1, Page 2, … and the tab-hborder, tab-vborder attributes set the amount of space around the label in the tab. The page attribute sets the start up tab while the tab-pos attribute sets the position of the tabs on the notebook: 0=left, 1=right, 2=top and 3=bottom.
Below is the result of changing this value to 0.

There are many dialog utilities around such as zenity, yad and gtkdialog that allow us to create utilities that exactly meet our needs, and yet remove the tedium of having to code in a more complicated language such as C++. As these utilities become more complex, using several dialogs of various size and shape, they generate a disjointed appearance with dialogs opening and closing, often with a short delay between the closing of one and the displaying of the next.
The notebook widget can be utilized in these cases to give a more uniform and professional appearance. Placing the contents of each dialog to be displayed on its own page in a notebook widget, and turning off the visibility of the tabs and borders of all of the pages, and then displaying only the page that is currently required produces a seamless effect to the operation of the utility.
This next example shows this technique in action having a start page that allows the user to choose between a utility that simply displays the current data and time or a system backup routine that displays the pages that are relative to the previous selection. Although the example utilities are trivial and I haven't actually included any code to perform the backup routine, the mechanics of developing utilities with multiple screens is functional.








The Timer and Expander Widgets
The preceding example introduces two new widgets, the timer widget and the expander widget. The timer is a simple widget that is used in the example to update the time and date displays. The default delay is one second and the default unit is the second, but finer control can be had by including the tag attribute milliseconds="true" which will then use milliseconds as the unit. Here I have used two timer widgets, one with a delay of one second to update the time display, and the second with a delay of one hour (3600 seconds) for the date display. When the time expires the action is performed and the timer reset and started over.
The expander widget allows us to make more options available to the user but still keep the display uncluttered by only displaying those options that are more likely to be chosen. Clicking the expander displays or hides the additional options.
The example also introduces "conditional programming' in the code for page 2.
<action>if [ "$RB_2A" = true ]; then echo 3 > inputfile; fi</action>
<action>if [ "$RB_2B" = true ]; then echo 4 > inputfile; fi</action>
Here the variables assigned to the radio buttons are examined to see if they are "true' (selected) and if so then the action is performed otherwise the action is skipped. The action in this case is to write a new value to the file input file. The notebook widget is sensitive to this file so that when radiobutton RB_2A is selected the value 3 is written to the file and the notebook displays page 3 -- seamlessly.
Although the above code looks dauntingly long, much of it is repeated and heavy use was made of copying and pasting to produce it. To add a new page to the notebook, simply copy a similar page and paste it in the order where you want it to appear, and then add, remove and re-order the widgets on the page. This also has the advantage of maintain a consistent look throughout the application. Pages are not numbered per se but consist of all of the code enclosed in a "first order' container, that means a hbox, vbox or frame that is exactly one level below the <notebook></notebook> tags. This code may contain its own lower order container widgets. In the example, all of the pages are enclosed inside vbox widgets.
The List, Table and Tree Widgets
These three widgets are all similar, with the list widget being the simplest and the tree widget offering the most functionality. For comparison, here are some screen-shots of each using slightly modified examples from the gtkdialog documentation.

The list widget displays a simple, single column list of items for the user to select from. The scrollbars can be hidden if required, and other features such as height, width and title may be configured, as with most other widgets.

The table widget allows us to display multiple columns with optional, clickable and resizable headers, which allow for auto-sorting using various algorithms to allow for things such as letter case. The data may also be sorted on initialization. Auto-refresh is available for when the data-input file changes, and if auto sorting is enabled, then the data will be re-sorted.

The tree widget is rather poorly named, not generating a tree structure as we might understand it. It does however do all that the list and table widgets do, and a whole lot more. With the tree widget, we can icons improve the user interface and selection of multiple items is allowed.
When used in conjunction with signals, the built in functions, and the power of the bash shell, this becomes a versatile data selection widget.
Which of these widgets you should use depends upon what data you have and what interaction will be required from the user.
Combined with a little imagination, it is possible to assemble some useful tools using the gtkdialog widgets with only a little programming knowledge. Although the documentation for gtkdialog is rather sparse, a few searches on the internet -- or, a little bit of trial and error -- will usually bring results. There is quite a bit more to gtkdialog than I have demonstrated in these few brief articles, but the groundwork has been covered, and may have given you some ideas for projects of your own.

More Templates: LibreOffice Plus!
by Meemaw
We see that Google has bunches of templates for use in Google Docs, but what if I want a template to use on my computer? At work, I may need a template for an invoice, an employee timesheet, or even a payroll record, but I don't really want that information on Google Docs. Do I need to open LibreOffice and try to create those documents? Nope. LibreOffice.org has a selection of templates that can be downloaded. A section of the LibreOffice site is devoted to Extensions and Templates. You can click on http://templates.libreoffice.org/template-center and find templates that are available. You will see a drop-down with categories, but you can search as well.

Also, to the right of the window is a "Browse Template by Category" list. Simply click the category you want.
Suppose I want to design a three-column brochure. I can search for "brochure" or I can use the drop-down or the list at lower right. There are two that I can download: one for LOWriter and one for LODraw. The quick-view for the LODraw file is shown below.

Download the template file, then open it in LibreOffice. You can begin designing right away, but if you plan to use it more than once, it would be a good idea to save the template. Choose File > Templates > Save Template. The template manager will open at All Templates. You can save there or you can create a new folder (a folder called My Templates may already be there for your use). Click to open the folder where you want to store your template, then click on Save. A small window will open asking you to name your template. Give it a meaningful name and click OK.


If you downloaded both brochure templates, make sure you have named them so they can be distinguished from each other.
Now that you have saved your template, go ahead and design your brochure. You will also have to save your brochure.
Just in case you haven't found the template you need in LibreOffice's template collection, you might try OpenOffice's template site. You will have to search, but as with all searches, the more specific you are with your search term, the faster your search will be.

Another good site for templates, and the one I use much of the time, is Vertex42. The site advertises itself as "... a leading provider of spreadsheet templates for Microsoft® Excel®, OpenOffice.org, and Google Docs." Many of the templates are available as both Open Document format and Office format, so you will have your choice. Vertex42 seems to be well-organized, and the categories down the right side make your search easier.

Download and installation is the same for LibreOffice, no matter where you get your template. Most of the sites also have presentation backgrounds for download.
While we are at it, we can find templates for Scribus as well. ScribusStuff has templates to use in our favorite desktop publishing program. In addition, we can also download templates for use in Inkscape here.
Depending on which site you visit, you can find most any template, from a personal budget planner to employee timesheets and from loan amortization schedules to graph paper. I hope you find the exact template you need!

LibreOffice Macros
by zerocool
OK, I admit it! I was an Excel wizard. Actually, that was my single greatest stumbling block preventing me from switching to Linux. I knew without dropping the Excel magic book of tricks I'd be spell-bound to Bill Gates. Luckily, after I found PCLinuxOS, I was highly motivated to write a new book of tricks chock full of open source magic. Granted, it wasn't easy. I had toiled long and hard for years in an effort to make Excel do my bidding. It had become second nature. It took time, effort and determination, but I can now call myself a LibreOffice Calc wizard!
Just like Excel, Calc supports a full programming interface, macros, and form control elements. Macros can be coded in LibreOffice basic, python, beanshell, or javascript. The form control elements range from standard push buttons, check boxes, radio buttons, text box, combo box, list box... A complete writeup on the use of all the languages and controls would surely be beyond the scope of this article. Rather, I will be discussing the use of LibreOffice basic to automate basic spreadsheet function via a few standard form elements. It's my hope that this might make your transition to Linux just a bit easier. So with that in mind, let's get started.
It goes without saying we can't start coding if we don't have LibreOffice office suite installed. PCLinuxOS utilizes the LibreOffice Manager application for accomplishing that task for us. So if it's not already installed, (in most cases it should be, but if not) open the Synaptic package manager and install LibreOffice Manager. Then run it and follow the screen prompts to install LibreOffice office suite. If you're having trouble getting it installed, please refer to the forums and ask one of our many helpful forum members for assistance. Then, open a new calc document.
The first basic functions we'll look at are reading the contents of a cell into a variable, performing some operation on that variable, and then writing the new value to a new cell. We'll then automate the process by attaching this little useless macro to a push button. Sounds fun right? Believe me, it really is.
So let's start by populating some cells. In A1 type "PC", in A2 type "Linux", and in A3 type "OS". Then open the macro programming interface by clicking Tools > Macros > Organize Macros > LibreOffice Basic. This will open the Basic Macros dialog.

Click on the little arrow next to "Untitled 1" (the spreadsheet name) in the left hand pane,

then select "standard" and click the "New" button.

Then click OK to open a new macro module called "Module1."

Referring to the image above, in the left hand pane we have created a module called "Module1". Modules can contain several macros and we could rename "Module1" to anything we like. In the right hand pane is our macro currently called "Main." Again, we could rename it to anything we like but we'll leave both as is for these purposes. As you can see, we have "Sub Main" and "End Sub" and any code we write goes in between these two statements.
Here's the code we're going to put in:
oSheet = thisComponent.Sheets("Sheet1")
oCell1 = oSheet.getCellByPosition(0,0)
oCell2 = oSheet.getCellByPosition(0,1)
oCell3 = oSheet.getCellByPosition(0,2)
oValue1 = oCell1.string
oValue2 = oCell2.string
oValue3 = oCell3.string
oRadicallySimple = oValue1+oValue2+oValue3
MsgBox(oRadicallySimple + " Radically Simple")
oCell4 = oSheet.getCellByPosition(0,3)
oCell4.string = oRadicallySimple
It will look like this when you're done:

Now we'll go over each statement and what it does. The first statement:
"oSheet = thisComponent.Sheets("Sheet1")"
This statement casts the name of the sheet we are using (in this case "Sheet1") into the variable oSheet. That's all.
The next statement is another cast, this time not only the name of the sheet--but also the cell we want to point at--into the variable oCell1. At this point we can think of the variable oCell1 as looking something like this:
oCell1(Sheet1,Cell A1)
In other words, it's now a reference to cell A1 on Sheet1. The next two statements simple reference cells A2 and A3 on Sheet1.
oCell2 = oSheet.getCellByPosition(0,1)
oCell3 = oSheet.getCellByPosition(0,2)
With the getCellByPosition values in column, row order.
This is great. Right? We now have pointers to the three cells which contain the data we want to manipulate. Now all we have to do is use those pointers to get the actual data contained in the cells and that's what the next three statements do.
oValue1 = oCell1.string
oValue2 = oCell2.string
oValue3 = oCell3.string
These statements simply say:
"set the variables called oValue1, 2, and 3 to the value contained in the pointers oCell1, 2, 3 and treat this value as a string as opposed to a number".
oValue1 is now equal to the string "PC"
oValue2 is now equal to the string "Linux"
oValue3 is now equal to the string "OS"
Next, we combine these three separate values into a single variable called oRadicallySimple:
oRadicallySimple = oValue1+oValue2+oValue3
oRadicallySimple is now equal to "PCLinuxOS". Next we pop-up a message box:
MsgBox(oRadicallySimple + " Radically Simple")
It will look like this when we run our macro:

and lastly, we write the contents of the variable oRadicallySimple to cell A4 like such:
oCell4 = oSheet.getCellByPosition(0,3)
oCell4.string = oRadicallySimple
Now, what good is having a cool macro like this one without seeing it run? So, to run our macro choose Tools > Macros > Run Macro.

Now, double click "Untitled.ods", double click "Standard", and click on Module1.

"Main" should be highlighted and click the "Run" button.
TADA!!!
Cool huh? But really rather tedious after about the tenth time! So let's fix that, too. Let's connect our macro to a push button.
First, make sure the form controls toolbar is turned on. Click View > Tool Bars, and make sure "Form Controls" is checked. Then click on the "Push Button" control. Then click and drag somewhere on your sheet wherever you want your button.

Now, right click on your new button and select Control. If your right click is not working, toggle the Design Mode icon from the form controls toolbar, and then try right clicking again.

This will bring up the buttons control dialog box.

Now, click on the "Events" tab and scroll down to the "Mouse button released" setting.

Now click the little button with the 3 dots at the end of that line.

Now click on the "Macro..." button.

From here, it's just like it was to run it. Double click "Untitled.ods", double click "Standard", and click on Module1, and when "Main" is highlighted click "OK".

Click OK again.

Close this dialog and toggle the "Design Mode" icon on the forms control tool bar. If you did everything correctly, you should now be able to run your macro by clicking the button.

Exciting right? You have just taken your first step into a much larger world! Don't be afraid to experiment and there are many great sources for expanding your knowledge of LibreOffice Basic. The possibilities are limited only by your imagination. I hope you all enjoyed it and maybe we'll do some more sometime soon. Till then, keep on coding.
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Game Zone: Tank Riders
by daiashi

About The Game
WANTED: Able-bodied recruits to fill a number of sudden... vacancies in the 153rd tiny tank battalion. Only the finest, bravest and buffest need apply. In return, we offer all the honour and glory you can eat, and a tiny, little tank of your very own. Join the fray in Tank Riders, a 3D tank battle game, which combines vibrant, colourful graphics, fast-paced action and exploration to create a package that will charm everyone -- from hard core gamers to wet-eared newbies. Attack hordes of oncoming baddies with an arsenal of cannons, missiles and mortars! Bounce shots off walls to hit lurking enemies before they have a chance to attack! Blast through walls and charge ahead, or find hidden paths to sneak up on enemies unawares!
I wasn't to sure whether to do a game review on something that runs in a browser. However, since it is available in the Chrome web store, and it can be played offline as well as online, I thought what the heck. If you were like me and grew up during the Atari 2600 years and remember Tank, Tank Riders will be a fresh take on the original. It is best played from a keyboard and mouse, since aiming seems to be a bit quirky. There is single player mode, as well as multiplayer. The games graphics look surprisingly good, and performance seems just as good as any install-to-play game out there in its genre. If you want a decent game and have some spare time, give this one a try.
System requirements:
Fully updated PCLinuxOS.
Hardware:
No real system specs that I could find - however, I am running it on a dual core Celeron 1.4 and 2 gigs of DDR3 and it's very smooth.
About The Company
Polarbit is an independent developer and publisher of video games and game development technology.
Founded in 2005, Polarbit have developed or published more than 30 titles for smartphones, Mac/PC and consoles. Notable titles include Raging Thunder 2, the Reckless Racing series, Crash Bandicoot Nitro Kart 2 and MLB World Series 2010.
A total of more than 80 million downloads of Polarbit developed and published titles stand as testament to their experience, dedication and uncompromising attitude towards quality.
Some Gameplay Screenshots





Getting It To Run
Fire up your browser and head to the Chrome web store and search for Tank Riders. Add it, and you should be good to go.


PCLinuxOS Family Member Spotlight: Ramchu
by Ramchu as told to Smileeb

How old are you?
60 years old
Married, single or what?
Married 17 years.
Children, grandchildren?
I have two children: a boy and a girl, and two step sons.
Retired or working and for how long and at what?
I am self employed in the HVAC industry for the past 10 yrs. Before that I was a welder in the coal mining industry for nearly 30 years.
What is the area you live in like? Weather, Quietness, Scenery.
I live in the United States in southern Illinois. The weather here is hot, muggy summers and moderately cold winters. It is a rural community and my nearest neighbor is a 1/4 mile from me. The town that I call home only has 7000 residents, so it is a quiet community and is located just outside of the Shawnee National Forest.
What is your education level?
I have a two-year college degree in AgriBusiness.
Do you like to travel, go camping?
I am not really big on traveling long distances, but I do enjoy boating, camping and 4-wheeler riding in the winter.
What caused you to try Linux and join this forum?
We got our first computer around 2000, and of course it was running Windows. As I became more familiar with the workings of computers, I started exploring other options. I started reading articles that kept referring to Linux. I first installed Ubuntu, joined their forum and was met with a lot of rudeness for being a noob to Linux, so I went back to Windows.
One day in 2008, I saw a reference to PCLinuxOS (I don't remember where), so I downloaded it and went to the forum and read how to install it as a dual boot. I did the installation, and about a month later joined the forum. I found this to be a really friendly bunch of people that were eager to help, and here we are today.
PCLinuxOS Family Member Spotlight is an exclusive, monthly column by smileeb, featuring PCLinuxOS forum members. This column will allow "the rest of us" to get to know our forum family members better, and will give those featured an opportunity to share their PCLinuxOS story with the rest of the world.
If you would like to be featured in PCLinuxOS Family Member Spotlight, please send a private message to smileeb in the PCLinuxOS forum expressing your interest.





Inkscape Tutorial: Tracing A Logo
by Khadis
On some occasions, I often help people to create or to re-create a logo they have. Mostly, they come with a bitmap logo (a scanned draft of logo) or come with low-resolution bitmap image. They often need a new logo that can be used or manipulated for later use. In brief, they need a vector format of a logo, which can be easily made using Inkscape.
The tutorial below will show you how to trace random simple logo I picked from my logo collection.
Step One: To trace a logo, we need the Bezier Tool (Shift + F6). Then, after this tool is in your hand, now draw a continuous line starting from point "A" to point "B".

Step Two: If your default line is hard to see, you can zoom the screen to get better view. You can also raise the stroke width and change the stroke color. For now, I changed the stroke width into 2 px and red as the color. We can always turn its color back into its original one, of course.
Step Three: Keep drawing the line by clicking on each corner until you get as pictured below (in the end, click on the starting point to close the curve/path):

Step Four: Using "Edit path by nodes" tool (F2), you can manipulate the path into desired shape (e.g. bend the straight line into a curved one).

Step Five: Using this tool, pull the middle part of the line. You will also get two handles which can be lifted up and down to bend the line. If you find the nodes you have are not enough, you can always add the nodes by double clicking your mouse on the path.
Step Six: After all parts have been bent, you can continue to another part. For the logo I traced here, I have a pair of symmetric wings, so I do not need to trace the remaining wing part, but later I can copy and flip it instead. In the picture below, I traced the middle part of my logo using 3 px-stroked blue curve so you can spot the difference.

Step Seven: Using "Edit path by nodes" tool (F2), you can bend the line following the original path (logo). The final touch will be like this:

Step Eight: Do the same steps for other parts. Now, let's insert text, as in the original logo. Using the Text tool (F8), type the text. I use Times New Roman 32 pt. Your font size may be different from mine because of the size of the overall picture.
Step Nine: Next, let's create a path as we will put the text on a path. For the path, I use an ellipse. To ensure that the text will flow on the path correctly, I drew an ellipse right under the original text to measure the required size. Look at the 4 px-stroked green ellipse below:

Step Ten: After you get the right size of your path (your ellipse), now put the text on it. Select your text and your ellipse, then go to the Text > Put on path menu. Your text will be placed on the ellipse. You might need to make some minor adjustments so that the text position fits your needs. After your text is positioned to your satisfaction, you can remove the ellipse.
Step Eleven: Finally, it's time to put a pentagon shape as the background. Please group all the objects first. After that, create a black-stroked pentagon (no fill color) using Stars and Polygon Tool (*). Adjust the size as you need and set the rounded into 0.100.
![]()
Step Twelve: You can then adjust the shape of this pentagon by converting it into path (Path – Object to path menu or press Shift + Ctrl + C) and re-shape it using "Edit path by nodes" tool (F2).
Step Thirteen: Now, align the grouped objects with the pentagon. Make them centered horizontally and vertically.

That's all. Now, you can trace any logo you want only by using Bezier curves.
![]()

Screenshot Showcase

Posted by coffeetime, July 05, 2014, running Openbox

Posted by daspicer, July 19, 2014, running LXDE

Posted by elana, Jult 10, 2014, running MATE

Posted by francesco-bat, July 22, 2014, running KDE

Posted by marcin82, July 05, 2014, running KDE

Posted by nymira, July 07, 2014, running MATE

Posted by Stephen, July 16, 2014, running KDE

Posted by Taco, July 06, 2014, running Openbox

Posted by tbschommer, July 22, 2014, running KDE

Posted by xredded, July 14, 2014, running Cinnamon